Too many redirects how do i fix

I’ve got 2 other domains set up fine over a year ago.

Tried to add another today and full of issues. It’s hosted on hostgator.

Installed wordpress, I can see the “hello world” but I’m getting the “too many re-directs” for the login page. If I set the SSL in Cloudflare to full then the login 404s me, if it’s paused then it 404s me along with a big warning; if it’s flexiable it just times out and says too many redirects.

If I login to one of the other domains with the cpannel and then go to my new domain then I get the banner thing on top that you see when you are logged on, but as soon as I try and get in the backend it times out again.

Any ideas?

The only possible thing I can think is it seems like the only DNS records that have been generated are x3 A records (“*”, “[my domain name]”) and an MX record.

My other domains all have a lot more; could that be causing a problem?

PS - I’ve tried searching “ERR_TOO_MANY_REDIRECTS” and it’s not helped!

Hello there,

May I suggest you to check this #CommunityTip

In terms of SSL mode, I suggest you to go for FULL strict. Please read this doc.

1 Like

I assume these are not the issue. However, I believe they are proxied :orange:

Yeah, I read it. Problem is that if I go to full then rather than “too many re-directs” on my login page(s) I get '404 this page doesn’t exist"!

There’s a difference between Full and Full Strict. You can read the doc attached above or you can :search: for more information on that as well.

404 error is a sign of no such existence of that page. Please check the url you are trying to browse.
There can be a few reasons as well. Are your records proxied :orange: ?

Thanks for the reply, but yes the page does exist… it timesout when on flexiable and only 404s when on full

To prove the point, I login to another domain via softaculous, and THEN type in my domain name, and I can see all the backend stuff at the the top for the wordpress site I’m trying to get to…

Then I press “edit site” and it times out again.

Either way putting it to full doesn’t solve the problem, and somehow 404s the login page

I’m close to just taking it off Cloudflare dns to get the website set up and then put it back on after I’ve edited it… but it seems ridiculous that I’d need to change the nameservers every time I want to get in the backend.

Please read this article. You’ll have a better picture where you are wrong. Especially the 524 & 525 errors.

I’m not sure how many times I can say that the articles aren’t helping before you’ll believe me.

Thanks for your help, I’d prefer it if you concentrated on helping someone else, and hopefully someone else might be able to help me without posting the same articles I’ve read.

I’m gonna try changing the nameservers to hostgator, reinstalling wordpress and seeing if I get the same issure. If I do then it must be a hostgator thing rather than a Cloudflare issue.

Able to get into that login link after removing Cloudflare (the same link that 404’d when on full, and timed out due to redirects when on flexible)

May I ask if you configured Cloudflare integration via Hostgator maybe for that particular domain?

Before moving to Cloudflare, was your Website working over HTTPS connection?

Was WordPress configured to work over HTTPS?

You could determine this by:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS without any error
  4. Check with your hosting provider / cPanel AutoSSL / Let’s Encrypt / Certbot / ACME and renew it in case if needed
  5. Only then, when your website responds over HTTPS, you should un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

Otherwise, I’d suggest as follows:

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

Switch all the DNS records from proxied :orange: to :grey: (DNS-only).
Wait for a few minutes.
Go to cPanel AutoSSL options and run it if it says it’s a self-signed or not a valid one.
Once it passes and the SSL certificate is renewed successfully, switch back from :grey: to :orange:.
Make sure all he e-mail related DNS records like A mail autodiscover cpconcats cpcalendars autoconfig webmail remain unproxied :grey: and that your MX record for has got the hostname
After that, set the SSL/TLS settings to Full (or Full Strict if it goes without errors) at Cloudflare.

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

Otherwise, have you tried to login to phpMyAdmin and check the SITE_URL and HOME_URL?, should be

Might be something with the web server configuration file like .htaccess if there is some HTTP(S) redirection defined once you’re on “Full” or “Full (Strict)” at Cloudflare.

Might want to try out:


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.