Too Many Redirects Errors with a Specific Data Center

We are receiving ‘Too Many Redirects’ errors on our website causing display and functionality issues. From testing it is only happening when connecting to a specific Cloudflare Data Center in Atlanta, GA (ATL).

I’ve used a VPN to connect to our website through the MIA, EWR, FTW, and LAX data centers, and the website loads normally.

If I set our account to Development Mode, the website loads normally through ATL. If I turn Development Mode off, the problem returns only at ATL.

I’ve tried a Full Cache Purge without success.

Is there anything that can be done at the specific data center to try to resolve this, or is there a way for us to exclude a specific Data Center for the time being?

I’ve never seen this happen in specific DCs.

What’s your SSL setting? Flexible I guess.
Can you share the domain with us?


Some more insight:

Correct, it’s Flexible. Unfortunately, it is the only option we are able to use with our current e-commerce platform.

Our domain is, although I currently have our account set in Development Mode, so it is currently loading normally.

I appreciate the resource info. I had already gone through that, and several other resources and threads trying to figure it out what could be causing it. When it first started happening, I thought it might just be an internal network issue or something that was device specific, because not everyone in the office was experiencing it, and we had not heard any reports from customers, and it seemed to come and go.

As strange as this is, we actually had a similar issue about a year ago that only affected users connecting through the MSP data center. The difference then was that CSS and JS files were being flagged as not secure, therefore browsers were blocking them. In this case, a few files are failing to load with the ‘Too Many Redirects’ error.

Please name and shame.


Any e-commerce platform that doesn’t offer free SSL should be kicked to the curb. It’s inexcusable to not encrypt any site that conducts monetary transactions.


1 Like

I completely agree, and I finally have buy-in from upper management to move to a different platform when our current contract expires.

We use NetSuite (owned by Oracle), and the website platform is SiteBuilder. To say that the platform as a whole has been neglected in recent years would be an understatement. Many others on the same platform believe this is in an effort to urge companies to ‘upgrade’ to a higher tier platform.

Anyway, here’s some followup info. Some things are still not making complete sense to me, but I think I have fixed the issue.

While testing yesterday, I was able to replicate the behavior at will by disabling Development Mode, which would reintroduce the issue, then using a VPN to access our site without the issue through other Cloudflare data centers. The ATL data center was the only one that would present the issue.

One weird observation is that there is one person in our office that has been seeing the issue the entire time, regardless of Development Mode being enabled or not. Our site would only load normally on his computer if Development Mode was enabled and he used Incognito Mode.

Another weird observation is that Development Mode would not be enabled first thing in the morning, and the site would load correctly for me and others in my office. However, as soon as the person mentioned above would check to see if the site loaded correctly for him, it wouldn’t load correctly for him and then it would stop loading correctly for the rest of us. It happened three mornings in a row.

This morning I started looking closer at the files that were failing to load, and noticed that each of them were coded into our site with the full HTTPS URL using the NetSuite domain, but the browser source code showed that the domain had been changed to ours, which was causing the redirect because of the URL path structure had an extra layer in the file path. There were about a dozen files, and I went through them one by one and updated the URLs to be relative URLs.

Since then, the site has been loading correctly for me and others with Development Mode disabled.

The person mentioned above still had issues, but only in Chrome. I had him completely clear his browser cache, which resolved the issue.

I’m not sure what the take away is for this, other than there were definitely some URLs that needed to be updated. Those URLs had been in place for a long time, so not sure why they just started causing issues. As far as the other oddities, like it only happening through a specific data center and being constant on a specific computer, maybe it was just coincidental?

Since the 2020.1 release of NetSuite, you can now set your SiteBuilder domain to be SSL enabled. In fact you can have NetSuite automatically add a free certificate if you don’t want to add one manually. We are using the Flexible setting but I’ll be installing the new certificate into NetSuite this weekend and will switch our setting over to Full.

This topic was automatically closed after 30 days. New replies are no longer allowed.

kentbigdog, you mentioned a month ago in a thread that you were about to install the free SSL certificate for your Site Builder site. I wanted to follow up to see how it went, and if you have any advice or suggestions for making the change as seamless as possible? Did you run into any issues during the process?

And, if anyone else has done this, I would appreciate any and all feedback.

On a side note, is there not a way to send DM’s to users in this community?

You should mention the user and the thread, to help give context.

Not for the vast majority of users.

1 Like

Appreciate the advice.

Here’s the thread I referenced: Too Many Redirects Errors with a Specific Data Center

Can you clarify the ‘mention the user’ part? Is there a way to actually tag kentbigdog on the thread?

Regarding DM’s, I thought that might be the case.

It’s done the same way as in Twitter, basically: @kentbigdog.

Will merge and reopen the other thread for a few days :slight_smile:

Got it!

Thank you!

1 Like