Too many redirects error

I’m experiencing an issue that happens recently only on chrome on mobile. When i type any link starting with http:// it gets auto redirected to https:// although im forcing redirect all https to http so it ends up getting error too many redirects. When i tried to pause CF on my site, i no longer get that error and http protocol functions normally. So, any tips how to resolve this issue while keeping CF enabled on my site?

Kind regards.


Thank you for askin.

Meaning, you don’t have an SSL certificate installed at your origin host, neither configured virtualhost file for any HTTP to HTTPS redirection? :thinking:

May I ask if under the SSL/TLS tab of Cloudflare dashboard for your domain name, is the SSL option set to “Off” (disabled), or rather you’re using Page Rules to disable SSL on your domain or a part of it? :thinking:

Other options like “HSTS”, “Automatic HTTPS Rewrites” and “Always Use HTTPS” are also disabled at Cloudflare dashboard → SSL → Edge Certificates? :thinking:

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

Today’s standards are quite good and secure. Unfortunately, there are some services which might require using insecure setup and a HTTP.

That’s also available for other Web browsers too nowadays, especially if you are using an option like “HTTPS-only”, from what it means you cannot open any HTTP website, only HTTPS.

They might do default HTTP to HTTPS redirection, or throw some warning, if so.

More about it can be read at the articles from below:

No, it’s flexible and http worked fine for years using these settings. This issue only started a few days only on chrome mobile but other browsers don’t redirect to https including chrome on PC and yes i tried on private (incognito mode but still having the same issue).

So you have HTTP → HTTPS, but from what I read you want vice-versa, HTTPS → HTTP, rather to say only HTTP? :thinking:

Disable the SSL at Cloudflare, if so.
I am not aware of any other settings which would force this.

Have you checked the HTTP headers of the requested URL?

Could you share the example of the URL so we could double-check, troubleshoot and provide some feedback information?

1 Like

Well, looks like the issue has been fixed after disabling the Universal SSL. Thank you, Fertix.

I am seeing the same thing with Chrome 104.
We use SSL for specific things but only a few URLS are allowed, the rest redirect to http and all of a sudden when proxied through CF Chrome will decide to only use HTTPS.
Like @eng_eg11 said, this was working fine for years and its only changed recently.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.