Too many redirects attempting to access Worker on subdomain and path

Hi all,

Link formatting

I apologize for the weird link formatting. It seems like CF won’t let me post links because I’m new to the forum.


I’m chiefly a front-end developer and maintain my company’s Shopif y Plus store. Our domain is

User story

I wrote a Worker and created a production and staging version of it. I’d like to eventually host them at* and*, mostly to add some CF firewall rules to these routes.


Whenever I hit anywhere within **, I receive ERR_TOO_MANY_REDIRECTS.

Steps taken so far

Worker Custom Domains and Routes seemed exactly what I was looking for.

After following the documentation to set up the staging environment first, this means I now have the following DNS record:

| Type   | Name         | Content              | Proxy Status | TTL  |
| Worker | | klaviyoproxy-staging | Proxied      | Auto |

More accessible list version of the plain text table above:

  • Type
    • Worker
  • Name
  • Content
    • klaviyoproxy-staging
  • Proxy Status
    • Proxied
  • TTL
    • Auto

I set the route* on the klaviyoproxy-staging worker.

I understand this config is not what I described in my user story. But during my troubleshooting, I’ve tried all manner of Custom Domain and Route configurations just to be able to access the worker anywhere on*. But I’ve always just gotten ERR_TOO_MANY_REDIRECTS instead.

I’ve searched the web for solutions. The more notable resources I came across are:

  • ERR_TOO_MANY_REDIRECT S · Cloudflare SSL/TLS docs
  • Community Tip - Fixing ERR TOO MANY REDIRECT S
  • Subdomain fetch causing redirect loop /t/subdomain-fetch-causing-redirect-loop/163817

I’ve tried all the troubleshooting steps in these that I can confidently perform.

But, because this seems to be an SSL issue, I’m concerned about how changing CF SSL settings will interact with the SSL that Shopif y provides domains connected to a store as well as all the other dozens of DNS records we have attached to this domain. You must use the TLS certificate provided by Shopif y for the store. SSL is turned off for in CF.

Any help or guidance on diagnosing and solving this issue would be very much appreciated!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.