Too Many Redirects After Installing Cloudflare

My site is jennsuzhoy.com. I have a Let’s Encrypt SSL Certificate with Dreamhost and have set my Cloudflare crypto to Full (strict), but am unable to access either the front or the backend of the site. On the front end, I am getting a Too Many Redirects error. On the back end, the login just refreshes when I type my username and password.

I’ve searched for an answer, but nothing seems to make a difference. Could this be DNS taking it’s sweet time, or is there something off about my setup? Appreciate the help!

Have you tried Full, but not Strict? In case you do, be sure to clear your cache - redirects are pretty sticky.

I did try this at your suggestion, but I am still unable to connect to my site.

The interesting thing is, when I go to my host dashboard (Dreamhost), and try to click Clear Cache, I get the notice that Dreamhost can’t connect to Cloudflare. Is there a setup step that I could be missing?

There are all kinds of redirects going on:
jennsuzhoy.com -> http://www.jennsuzhoy.com/
http://www.jennsuzhoy.com/ -> https://jennsuzhoy.com/
https://jennsuzhoy.com/ -> https://www.jennsuzhoy.com/
https://www.jennsuzhoy.com/ -> https://jennsuzhoy.com/

It’s those last two in the loop. Wordpress thinks your site doesn’t have www in front. Something else, somewhere, is trying to put www in front. As I recall, DreamHost has a hosting option to use WWW, No-WWW, or Either. Make sure it’s not set to WWW (should just be set to No-WWW, to agree with WordPress).

Unfortunately, the WWW one goes through Cloudflare, and the non-www doesn’t. If you’re still stuck, contact DreamHost Support, as they’re the ones in control of your configuration.

Thanks! I’m on a chat line with them now. I’m using the free version of Cloudflare, which means I HAVE to use the Add WWW option. I think I now understand what might be going on though, and I should be able to update Wordpress to match. Thanks for taking a look!

1 Like

Confirmed and solved! I was able to update my Wordpress URL via the wp-config file and all is well. Thanks and have a great night!

1 Like