Too Many Redirects Access application when Zaraz enabled

Has anyone noticed in the last 30 minutes a problem where you would get a code to access a resource behind a protected application but get a “Too many redirects” error?

This works again when Zaraz is disabled.

Because this is happening on the dev subdomain I have created a page rule to disable Zaraz on that only - but it also happens on other subdomains I’ve tested.

Hi @freitasm, Yair PM of Zaraz here. Did you reach out for support? Let me know if it’s a pressing issue and I see how we can help. But I would recommend in the meantime to contact support.

Hello,
This is Venkat from Support at Cloudflare. I wasn’t able to find any support ticket from you. Is this issue still occurring? I wasn’t able to reproduce any such errors on my protected application behind Cloudflare Access which also has Cloudflare Zaraz deployed on it. Please can you open a new support ticket to work with us to get the issue resolved.
Thanks.

Thanks @yair-dovrat and @vchintha

I have disabled the rule blocking Zaraz on this sub-domain and tried accessing it again. It asked for the email as expected and it behaved ok this time.

It could’ve been something happening yesterday. What I noticed back then:

  • Accessing the sub-domain access application with an IP Bypass policy worked
  • Accessing the sub-domain access application with an email groups policy failed with too many redirections.

It wasn’t great because it worked for me at home (static IP) but someone who had to review some code implementation was getting the errors (email group policy).

As I said, it’s working today for email group policy. I will keep an eye on it and raise a ticket if needed.

Thank you @freitasm!