TLS/SSL error website not working anymore

Greetings,

Thank you for asking.

I am sorry to hear you are experiencing an issue/error with your domain while using Cloudflare.

When try to access your Website, I got SSL_ERROR_NO_CYPHER_OVERLAP.

More information about this error can be read at the article from below:

Before moving to Cloudflare, was your Website working over HTTPS connection?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Nevertheless, when there also seems to be missing the DS record for the DNSSEC?
Is the DNSSEC enabled or disabled at the Cloudflare dashboard for your domain name?

May I ask to:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
  4. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard: