TLS error on older Androids?

Starting at about 6 November 03:00 UTC we started to see users of our apps get TLS errors connecting to our API services, but only on Android versions 6 or lower. Has anyone else seens similar problems?

We see a TLS handshake error when we run the mobile app in a debugger. A screenshot would just show our app’s error dialog, and so not add any info.

For now we’ve just disabled Cloudflare proxying to avoid the errors.