TLS certificate does not include domain name?

I am attempting to validate my Twilio account, and it is asking that I provide the TLS certificate and private key. (“Generate a Certificate Authority signed TLS certificate and a private key (for the specific subdomain if relevant)”).

I have tried to do this many times and continue to receive this error from Twilio: “Certificate’s domain name does not match the registered domain. Registered domain:, Certificate domain name: Cloudflare Origin Certificate”

I am also noticing in my admin dashboard that CN = Cloudflare. Not sure if that’s relevant. My domain is

Any help is greatly appreciated!

Welcome to the Cloudflare Community. :logodrop:

Cloudflare Origin CA certificates are only valid for connections between the Cloudflare proxy and your origin server.

Can you share a link to the Twilio guide that you are writing from?

Hello! I’m encountering the same issue. Below is the information on Twilio’s site. Could this be solved with Custom Hostnames?

Upload a Transport Layer Security (TLS) certificate and private key to allow Twilio to serve redirects over HTTPS from your selected domain. This will ensure we have a trusted connection with the requesting clients (customers’ browsers) and Twilio’s servers. Read step by step instructions

Messaging Services | Twilio

I was able to get it working with w w w

I uploaded that information into Twilio and it worked. I am a total novice so am not sure why it worked, but I hope this helped.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.