TLD .dev domain and ssl cipher mismatch error

Of all the domains i have, free plan or not, I have a problem with domain only, so I suspect it may be connected specifically to .dev domains.

Without CF it works fine with let’s encrypt. Trying to add domain to CF results in empty list of “automatically detected DNS settings”, which I found suspicious.

Immediately after DNS propagation all subdomains within stop working returning ‘ssl error cipher mismatch’.

Tested here: and got "can’t connect to secure server’.

Tried enabling and disabling universal ssl, clearing caches, waiting for dns caches to clar, changing strict to flexible, even removed domain from CF and added anew, but still no luck.

Did anyone else had problems with .dev domains, or am I on the wrong tracks trying to tie it with ssl errors?

For starters, post a FULL PAGE screenshot of your SSL/TLS app.

Here it is:

First of all, switch that “Flexible” back to “Full strict” and make sure you have a certificate on your server. Second, enable universal SSL at the bottom.

“universal ssl” switch must have accidentaly got stuck last time I played with it. Anyway I’ve already tried every type of certificate policy, to no avail. Https works only if I disable Cloudflare and returns “let’s encrypt” and TLS 1.2

Have you enabled universal SSL now? Have you switched to Full strict?

Yes, I did.

Can you post a screenshot of the first section of your SSL/TLS app?

If you enabled it, Cloudflare should now issue a certificate. That can take a while but should eventually work.

Well, the certificate is properly in place now.


Not sure if short ttls have anything to do with certificate issuing or disabling, but changes in SSL/TLS app settings can be seen on my sites in minutes.

Anyway - error persists. I tried for a week before creating this post to be sure nothing is cached or not propagated properly.

Which error? As evident from the screenshot it loads fine now on HTTPS.

Update - only one site seems to return an error now. Must be something on my side of things :confused:
Thank you for your help :slight_smile:

Hm, looks like it worked for a couple of minutes and then stopped working again. I’ll wait 24h and let the community know about the results. Maybe something is cached somewhere.

Still loads fine


Must be a local issue

Ha. So I found out it works fine in opera, but not in chrome mobile/desktop. Despite clearing and purging everything I could. Now, that’s very local issue :slight_smile:

This topic was automatically closed after 30 days. New replies are no longer allowed.