Timeout issue

We are having issues on requests which has more than 100 seconds and after that it we are getting cloudflare timeout. How we can increase response time in cloud flare.

You cant. You either have to make sure your process finishes within 100 seconds or unproxy that record.

1 Like

Unless you have an Enterprise plan :smile:

Enterprise customers can increase the 524 timeout up to 600 seconds.


Well you can also a. modify your process so it sends a keep alive request or b. run that request through a non-proxied hostname. Long running processes are a great DDoS vector.

1 Like

I somehow assume that wont be an option for the OP.

You mean on the same TCP connection? Via an HTTP 100?

1 Like

unproxy that record means?

Switching it from :orange: to :grey: but keep in mind this will reveal your IP address and you wont be using Cloudflare’s services any longer.

Something like

Though I am sure there are probably cleaner ways to implement.

Fair enough, but thats still splitting the requests. So the same TCP connection can never last more than a hundred seconds on Cloudflare?

On self serve plans this is not a configurable option and the default of 100 seconds is used.

Sure, by default, I was referring to any keep alive tricks on HTTP 1.1 or possibly 2.

This topic was automatically closed after 30 days. New replies are no longer allowed.