This site can't provide a secure connection with old PC

hello there my site is showing "This site can’t provide a secure connection [buildwithusagency.com](http://buildwithusagency.com) uses an unsupported protol. ERR_SSL_VERSIOON_OR_CLPHER_MISMATCH

But at my Dell Intel inspiron chrome, the browser is working fine, but at another mini-Pc is having this issues, i updated the chrome, change browsers, it showing that issue, i have done a lot of debugging but issues still persist, what can i do to solve this problem. am worried about my user experience

Die you read this one?

https://community.cloudflare.com/t/community-tip-fixing-err-ssl-version-or-cipher-mismatch-in-google-chrome