This Site Can't Provide a Secure Connection when it is proxied through cloudflare

When my DNS status is set to proxied I get this message:


I have seen articles saying to change it to non-proxied but then I can’t use cloudflre CDN which is the whole reason I came here.

I tried disabling, enabling etc. but it still doesn’t work.

It sounds like a certificate was not successfully added for your site.

It works without cloudflare.

What’s the status of the Edge certificate?

I turned the SSL Status off since I already have an SSL Certificate installed.

Hi @robertzou1234,

If you have your site proxied through Cloudflare and you want it to work with HTTPS, you need to set that to Full (Strict). Setting if to Off will result in that error as there’s no certificate for your domain on Cloudflare’s edge. If you want to directly serve the cert from your origin, you would need to unproxy the records to bypass Cloudflare completely.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.