"This site can’t provide a secure connection"

ssl
wordpress

#1

Hi,

I’m getting this result on my Wordpress site:

"This site can’t provide a secure connection

bankirr.com uses an unsupported protocol.
ERR_SSL_VERSION_OR_CIPHER_MISMATCH"

I’ve tried looking through similar problems on here, but the responses aren’t helping me. I’ve had a couple of web developers look at my site, but they say my Cloudflare account status looks fine other than one thing… If I go to the Crypto area within my Cloudflare, it’s showing the following:

"SSL

Encrypt communication to and from your website using SSL.
It may take up to 24 hours after the site becomes active on Cloudflare for new certificates to issue.
Status Authorizing Certificate"

…Any ideas? :s

Thanks in advance for any assistance!

Regards,

Scott


#2

This seems to be an ongoing issue. Have you opened a Support ticket yet?


#3

Sdayman, thanks for your time. I have opened one now…

It’s a shame, I feel like it must be something really simple but I just can’t for the life of me see what it is!


#4

Hi Scott - One of our agents is working your ticket now and may have identified a unique issue for escalation. He should provide more detailed information via the ticket soon.


#5

Hi,

Are there any news?

I believe that I have the same problem here https://www.banko-sistemi.com.
Everything was fine. Website was up and running until yesterday.

I use Cloudflare and Really Simple SSL plugin on this WP site.
Flexible SSL is in use.


#6

I guess that this is related to domain name.
I just notice that first 4 letters are BANK.
Domain name posted by scott1 also has those first 4 letters.

Maybe I should open ticket?


#7

try Flexibale mode
fix all the mixed content
redirect to https


#8

But everything was fine and I already use Flexible SSL. There was no problem with mixed content, and site was up and running for a quite long.


#9

This is definitely related to first 4 letters (BANK).
Here is the link with all abandoned certificates https://censys.io/certificates/3bbe4a1ff5577b58ebe9fd9fc72242c64e524e4636f39654167d1845d0066feb
My domain is also listed there.

How can I fix that?
Website is not related to any bank or financial services.
Those first 4 letters are taken from first and last name of the website owner: Bane Kovacevic.


#10

banko, I think you are correct. Cloudflare’s support have indicated they think this may be the case and are looking into it - I’ll keep you posted if I hear anything back.

In the meantime if you find a way to fix it, please let me know also!

Cheers,

Scott


#11

Hi Scott,

Thank you for the update.
Sure, I will let you know.

Best regards,
Banko


#12

Hi,

I am also facing the same issue on my website - https://www.crispyprice.in
This site can’t provide a secure connection
www.crispyprice.in uses an unsupported protocol.
ERR_SSL_VERSION_OR_CIPHER_MISMATCH

I have installed my OWN Comodo SSL on my server and also enabled Full (Strict) in crypto tab (Cloudfare settings).

How we can fix this problem.

Thanks


#13

Does the issue persist when you change to other SSL options?

Also, have you already checked against the suggestions in this KB article?


#14

Same here :confused:


#15

Yours looks to be DNS-related, as discussed in your other post.


#16

I have the same issue https://support.cloudflare.com/hc/en-us/requests/1499749?page=1
:confused:
I think it’s cloudflare’s internal bug.

A few days ago my website sudden get an ’ ERR_SSL_VERSION_OR_CIPHER_MISMATCH ’ SSL Error, I have rechecked all options but still not work,so I have to diabale the cloudflare cdn on my domain to resolve this question.

But I thinks it’s cloudflare CDN’s internal error, because when I click ‘Enable Universal SSL’ in cloudflare, get an “Internal error encountered while processing change (Code: 1005)” Error.

But my other domain on Clodflare is well.