This site can’t be reached ashnahub.com took too long to respond

Hi, I changed my DNS IP address, and 48 hours passed but still showing this.

Greetings,

Thank you for asking.

I am sorry to hear you are experiencing an issue with your domain/website while using Cloudflare.

I can confirm Website load fine on two different ISPs, one on my desktop PC and the other on my mobile phone (4G LTE) and both are returning over an proxied IP from Cloudflare network:

Furthermore, if you recently changed your domain nameservers, regular DNS propagation time usually takes up to 24-48 hours to complete.

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

I tried incognito mode and chrome, Mozilla firebox nothing works except VPN. Yesterday it was working fine for me but some users talking ■■■■ like can’t open the site error is showing. I thought maybe they have to wait 48 hours. So I ignored them. But now I can’t even log in without using VPN.
.

hey man, Do you think I need to change my nameservers to default nameservers with Godaddy’s IP address. i think that might solve my problem

I’d suggest you to not revert the domain nameservers back to old ones. I think we should wait a bit more then.

Have you tried using the “Purge Everything” button to clear the Cloudflare cache, just in case, from the Cloudflare Dashboard → Caching → Configuration? :thinking:

They said they can fix it in 5 min, just change your nameserver to your hosting server.

No need.

Yes, sometimes even 72 hours for some domains to complete and fully propagate nameserver change.

Have you tried restarting your home router? :thinking:

DNS propagation is ok:

I click this button on yesterday “Pause Cloudflare on Site” do you think this might be the cause of the problem?

Currently, it’s unpaused and proxied :orange: as it should be.
I can open your Website normally on 2 different ISPs.
No need to Pause Cloudflare now coz it’s working.

I can see by the HTTP headers coming, you are using some kind of a cache plugin or cache system? :thinking:

The below one (not related to the Cloudflare):

x-backend: local
x-cache: cached
x-cache-hit: HIT
x-cacheproxy-retries
x-fawn-proc-count

Try clearing that on hosting first, if so.

Yes, I used the wp rocket. The caching plugin

O-oh, that’s a new information and below are the suggestions to implement propperly to make sure your Website works fine.

Nevertheless, double-check and make sure under the Caching → Configuration → “Browser Cache TTL” is set to “Respect Existing headers” from the dropdown menu.

Regarding to the WP Rocket, kindly, may I ask you to follow the instructions how to propperly setup WP Rocket while using Cloudflare as follows on below articles:

In case you get some error to add IP to Cloudflare, you could achieve this by adding the origin host/server IP by navigating to the Security → Tools → IP Access Rules, enter the IP, select the action “allow” for your website :wink:

Here is a screenshot of an example:

Helpful article:

ok man I tried to configure all settings of wp rocket. Now I should wait 24 hours right? Maybe I changed my IP address wrong or something