"This link is not valid"

I’m trying to verify my account. CF sends an email which asks me to click a link to verify my email. I do 3-4 times and still get the message “ This link is not valid…”. I’ve tried multiple browsers. I’ve tried incognito mode.
image

We saw similar reports of this a while back, are you still encountering the issue? If so, is it with the same account you are using here? Sorry for the issues.

Yea, this account

1 Like

Thank you, sorry for the issue you’re hitting. I noticed a few similar reports (<6) over the past few days, all appear to have resolved with time as no apparent action was taken.

If you log out of dash.cloudflare.com and send yourself a verification, does the link you receive work? https://dash.cloudflare.com/forgot-password

If possible, you may want to try the link from a different device and/or in incognito mode.

After trying the link from incognito mode, I have successfully reset my password and authenticated the account.
Your advice is very helpful, thanks Cloonan have a nice day!

2 Likes

Fantastic, really sorry for the frustration with that and thank you for confirming. Let us know if anything comes up along the way.

2 Likes

I ran into this just now too, link failed three times in a row. Incognito mode did not help.

I logged out, used “forgot my password” then logged in from the email without resetting password. Then logged out again and logged in again and then sent verification email and this one worked.

2 Likes

Thanks, incognito mode did not worked for me either, I just logged out and re-logged in twice, then it worked, feels like some cookie-cachey-session-bug.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.