This hostname is not covered by a certificate [How Can I Fix?]


Hi everybody. I have completed the nameserver setup and waited more than 24 hours but the error is still being displayed.

Cloudflare confirmed that I had completed the domain validation process, but the error still appeared.

Do you have any “Edge Certificates” here?

https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls/edge-certificates

2 Likes

I plan to only use the free version and have no intention of paying because my website is quite new. 1 year ago everything setup was simple because I just needed to add a domain. Can’t I use a free SSL certificate? Because I only need to protect my main domain and www.mydomain

No one is suggesting that you move away from the free Universal SSL. @DarkDeviL was trying to ascertain whether this might be the solution you need.

1 Like

I was facing the same issue here and this solution worked for me. Thanks!

1 Like

Amazing. This is the simplest and most effective way. I tried and succeeded. Thank you very much!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.