This hostname is not covered by a certificate error when adding A record of website into DNS

Hello,

I’m just trying to add a new website to cloudlare and when adding my WWW and root A records for it gives me:

This hostname is not covered by a certificate

And a yellow exclamation mark. Any ideas? It’s a free plan.

Thanks
Rob

This might be a shot in the dark, but is there any chance you Disabled Universal SSL? It’s at the very bottom of the Edge Certificates settings.

I created my Cloudflare account today so it’s all on defaults, and I checked, Universal SSL is turned on.
Wondering if Cloudflare have an SSL glitch at the moment.

@user6030

Would you try again? You may share the error screenshot here.

This post was flagged by the community and is temporarily hidden.

This post was flagged by the community and is temporarily hidden.

Looks to me bit related to this? :thinking: if at all? Or …

No issue for me at the moment. Try troubleshooting:

Sure, same issue.
I’ve done this before for other sites, no issue. Should be fine it’s just staightforward brand new free Cloudflare account and I am adding 2 x A records for www and root for the website.

See attachment.

@user6030
It looks to me that’s quite related to this: as the warning note says:

Verification pending

I figured it might be that, not sure how they verify ownership exactly.
Let’s see what happens in 24 hours.
thanks

What would happen if I change nameservers to Cloudflare whilst it says verifying? Would DNS function or would my site die?

You need to transfer your nameservers for SSL to issue for your domain, so the pending message is the reason you don’t have SSL.

Switch your nameservers now - but first follow this guide to reduce downtime:

3 Likes

DNS will function with zero interruption.

If you want to avoid risks of any issues with the HTTPS proxy side of things, “Pause” your site in Cloudflare, update the nameservers, and once the certificates is ready and you’re at the console to monitor unpause your site to enable the remainder of Cloudflare’s services.

Thanks I followed the guide above and I will disable proxying, switch nameservers and then wait for SSL to be sorted, then enabled proxy.

I will do it on weekend to be sure, thanks.