They tried to attack my website, but instead of putting it down, only the freedom DNS doesn't work

So I have this website, l-----.cf, and a group tried attacking it. I don’t know what type of attack it was but it didn’t affect my hardware or my server. In fact if I connected thought ip, it worked all fine. But whenever I try to join through the freedom domain (which didn’t just expired or some like that) it won’t even load the page. It just keeps loading on and on. Idk what to do. Do I change domain or try something ?

Could you share the domain and send a screenshot of the error?

Try connecting to leosoftwares.cf but it won’t even connect, it keeps loading and times out

I suggest you take a look at and follow the steps in this help article - especially make sure you aren’t blocking Cloudflare IPs and that your server IP didn’t change.

I checked the DNS page, nothing changed, i use a proxies CNAME record connected to a other ddns that works and automatically updates whenever the IP change. And, I quote, when I try connecting to the site via the ddns it works, but when I try with the actual domain (leosoftwares.cf) it doesn’t

Could you setting the CNAME record to “DNS only” :grey: (or “Pause Cloudflare on Site”) and observe whether the issue has gone away? If it starts working after that, then you’re probably blocking Cloudflare IPs.

Yes, your domain isn’t loading


Steps are on the following link (https://support.cloudflare.com/hc/en-us/articles/200170196-Responding-to-DDoS-attacks)

i tried all the methods you listed down here but none of them works. The AppleSlayer does not work beacause i’m not under attack now, it’s more like the aftermath, they didn’t even touch my hardware and machines but the domain managed by cloudflare doesnt work. The last thing i’m assuming, is that my router blocked cloudflare ips but i need to check later with my ISP. Also putting the CNAME record on dns only does not work. Only things that kinda works is when i set my modem firewall to low, it show a 521 status code, instead of the 522 status code. That’s all i got

If you’re hosting this on a residential ISP, it wouldn’t surprise me if your ISP is blocking inbound connections since they probably don’t permit running servers on your account.

I suggest you follow Albert’s advice and bypass Cloudflare until you get that site up and running again, and with HTTPS so it’s secure.