There is an unknown connection issue between Cloudflare and the origin web server

Hello, I am at a point of trying anything. My website is working fine and have used cloudflare for 3 years now. All of a sudden, the metacrawler for Alexa stopped working. When I worked with Alexa certify to see what they are getting, they are getting a 520 error through my cloudflare. I have been working with my admin to see what is going on but nothing has worked. These are the logs i am getting:

www.confreaksandgeeks.com

Host

Error
            </div>

        </div>
    </div><!-- /.status-display -->

    <div class="cf-section cf-wrapper">
        <div class="cf-columns two">
            <div class="cf-column">
                <h2>What happened?</h2>
                <p>There is an unknown connection issue between Cloudflare and the origin web server. As a result, the web page can not be displayed.</p>
            </div>

            <div class="cf-column">
                <h2>What can I do?</h2>
                      <h5>If you are a visitor of this website:</h5>
  <p>Please try again in a few minutes.</p>

  <h5>If you are the owner of this website:</h5>
  <p><span>There is an issue between Cloudflare's cache and your origin web server. Cloudflare monitors for these errors and automatically investigates the cause. To help support the investigation, you can pull the corresponding error log from your web server and submit it our support team.  Please include the Ray ID (which is at the bottom of this error page).</span> <a href="https://support.cloudflare.com/hc/en-us/articles/200171936-Error-520">Additional troubleshooting resources</a>.</p>

Hey @dgreen
Have you check through #CommunityTips
Community Tip - Fixing Error 520: Web server is returning an unknown error

Also this, will directly help you.

Yes I have. I have done everything under the 520 error list and nothing is changing

ok @dgreen , you have send us the error code, however, you have’t provided more information about the the metacrawler for Alexa.

Steps to troubleshoot and identify any error.

1st of all if you, or your System Administrator believes that this is an error on CloudFlare, what steps have you taken to verify that?
For an example, if I were you, I would set CloudFlare on Development Mode.

Development Mode temporarily suspends Cloudflare’s edge caching, minification, polish, and railgun features for 3 hours unless disabled beforehand. Development Mode allows you to immediately observe changes to your cacheable content (like images, CSS, or JavaScript).

To enable Development Mode :

  1. Log in to your Cloudflare account.
  2. Select your domain.
  3. Select the Caching app.
    Toggle Development mode to ON.

You can also turn CloudFlare If you :grey: your domain it will disable all features except DNS.


You can also create a page rule to disable caching:

2nd, have you or your System Admin tried to get a response from the corresponding URL (the metacrawler) from your server, and then from another server which it’s domain do not use CloudFlare ? and if yes, what are the results.

Another thing I would also check is the Rocket Loader,
If you have specific scripts you want Rocket Loader to not optimise, you can do this by modifying your HTML script tags: How can I have Rocket Loader ignore specific JavaScripts?

Lastly, can you send me more information about the Alexa’s MetaCrawler, is it a script, is getting called from an URL?
In general try to give us more information, and then we will be able to help you more.

1 Like