The Wordpress theme editor is not loading whilst the proxy is turned on for the DNS. Why would this be?

For some reason, when the Proxy option is turned on for the DNS record that is pointing to my hosting account, the website runs fine but the Wordpress Theme Editor will not load.
I can’t understand why this would be the case. Is it preventing it from loading something from a different domain?
It isn’t a problem across the Wordpress admin area. Only when trying to access the theme editor.

Without seeing the console and errors - I would guess that this would either be - Minification (disable them in Speed tab if enabled) or Rocket Loader - again disable via the speed tab.

You would need to purge the cache (after disabling the features) before testing again

Thanks for your response.

I’ve gone into my Cloudflare dashboard and disabled the only compression settings that I could see as being turned on for this domain (Brotli). I can’t see anything called ‘Minification’ specifically, or ‘Rocket Loader’ for that matter. But the HTML, CSS and JavaScript options are all turned off.

I flushed the caching on the server itself, and within the Cloudflare dashboard for the domain.

Unfortunately, the issue is persisting.

When I look at the errors in the console whilst I’m trying to load the Editor, there are quite a few that all fall under these two categories:

  • Mixed content (45 errors): load all resources via HTTPS to improve the security of your site (Even though the initial HTML page is loaded over a secure HTTPS connection, some resources like images, stylesheets or scripts are being accessed over an insecure HTTP connection. Usage of insecure resources is restricted to strengthen the security of your entire site.)
  • Verify stylesheet URLs (8 errors): This page failed to load a stylesheet from a URL.

I’m imagining this means that the proxy is preventing the Editor from framing the website how it would usually, for me to make my style edits?

Thanks for your help!

Thanks for the context. So it would be Chrome blocking the http urls from loading in yoru browser (when the main site is loaded over https) - you can enable the below to see if this fixes the error.

Alternativly - you may have to install a plugin to fix this - it will convert all http to https in urls - How to Fix the Mixed Content Error in WordPress

Hi,

Apologies for the slow response. I’ve been unable to look at this again until today.

I can confirm that I have got it working again! It seemed like the ‘Automatic HTTPS Rewrites’ were already enabled, but once I navigated to this section of the Dashboard I thought I would turn on ‘Always Use HTTPS’ as well.

I also turned my ‘SSL/TLS encryption’ setting on to ‘Full’.

I’m not sure on which of the two might have been the solo solution, but the Template Editor is now working and I see no reason to revert either setting :slight_smile:

Thanks for your help @mbullock

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.