The website is not being loaded because of SSL issue

I am having an issue with SSL, It is displaying “This site can’t provide a secure connection” and universal certificate status showing “Pending Validation” and is not being reflected.

Greetings,

Thank you for asking.

I am sorry to hear you are experiencing an issue with the Universal SSL certificate provisioning for your domain name.

May I ask if your domain name is using the correctly assigned Cloudflare nameservers associated with your Cloudflare account? :thinking:

Furthermore, are the DNS records existing and proxied :orange: at the DNS tab of Cloudflare dashboard for your domain name?

May I ask how long is it like that? 24 hours or even longer? :thinking:

Have you tried temporary Disabling Universal and re-enabling it from the Cloudflare Dashboard → SSL/TLS → Edge Certificate → scroll down to the section " Disable Universal SSL"?

If you open up the Developer Tools (F12) on the SSL/TLS → Edge Certificate page, it should also show the actual error which would be very useful to know.

Before moving to Cloudflare, was your Website working over HTTPS connection?

How did you setup your domain name with Cloudflare? Like some kind of a partial setup or full setup? Maybe it was a CNAME setup?

Did you used some 3rd-party service or some hosting partner, or like WPEngine, eZoic ads, Shopify?

Furthermore, did you enabled the DNSSEC feature maybe?

What happens when you temporary unproxy, switch to :grey: (DNS-only) or temporary enable the “Pause Cloudflare for this site” option from the Overview tab of Cloudflare dashboard for your domain name? :thinking:

You can determine this by following below instructions:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
  4. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

May I suggest below article for help and troubleshooting:

What is your domain?

Its working now, thank you!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.