The Speed test could not run. returned a status 404. Try the options below to fix the issue

Hi people of cloudflare, I am having some issues. When doing a speed I get an error message that states, “The Speed test could not run. returned a status 404. Try the options below to fix the issue.”

Any help would be greatly appreciated!

notes: I followed a video online and have a few page rules setup.
I have routed the DNS from godaddy to cloudflare

It’s probably testing HTTPS to your server. Does your GoDaddy site have SSL configured on the server?

I think that it did. It was included. Would I disable it on Godaddy and use one on Cloudflare?

That would not be good. What’s your SSL/TLS mode here? Is it Full (Strict)?

Other than the speed test, is everything else ok?

SSL mode is full and yes everything else seems to be working.

That’s about all we can do from here. I suggest that you contact Support and see if they can see why it’s getting a 404.

To contact Cloudflare Customer Support, login & go to and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.


Hi @hartlmaiercody, sorry for the trouble. I noticed your ticket with Support and have added myself to it to keep track of progress.

I started seeing 404s on the speed page earlier this year but don’t know that I’ve seen a consistent solution. In looking at similar issues, here are some options to test one at a time/question to answer while waiting for Support to reply -

  • We have seen issues with the 404 and the speed app on CNAME setups, but your set up appears to be full, listing this item here as reference for anyone that views this thread later.
  • Are you using Mozilla or Chrome to run the test? If Mozilla, can you try Chrome and attempt to run the test again?
  • Can you disable TLS 1.3 and then attempt to run the test again?
1 Like

Hello Cloonan,

To answer your questions,

  1. Correct, the setup using full. I contacted go-daddy and was told my IP address may not be configured properly and that because I have the name address routed to Cloud-flare I must wait 24-48hours. I believe I did follow instructions when doing this correctly.

  2. I am using Chrome and have ran the test a handful of times.

  3. I ran a test after turning TLS off and the am brought to the same message.

Thank you for joining post,


1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.