The speed test could not {mywebsite.dev} returned a 503 error however Chrome returns ERR_CONNECTION_REFUSED

When I try to run a speed test for my site I see this error


When I open it in Chrome I see this error

Are these errors related or what? And how do I fix this?

What is the domain?

testcoders.dev

That domain is not using Cloudflare.

Port 443 is not open at the origin server. The .dev TLD is on the HSTS preload list, meaning browsers will force HTTPS.

[[email protected] ~]$ nmap -p 80,443 testcoders.dev
Starting Nmap 7.92 ( https://nmap.org ) at 2021-10-20 16:21 CEST
Nmap scan report for testcoders.dev (149.210.128.155)
Host is up (0.029s latency).
rDNS record for 149.210.128.155: 149-210-128-155.colo.transip.net

PORT    STATE  SERVICE
80/tcp  open   http
443/tcp closed https

Nmap done: 1 IP address (1 host up) scanned in 0.87 seconds

Furthermore, there seems to be a redirect loop at your origin:

[[email protected] ~]$ curl -i http://testcoders.dev/
HTTP/1.1 301 Moved Permanently
Server: nginx
Date: Wed, 20 Oct 2021 14:21:00 GMT
Content-Type: text/html
Content-Length: 178
Location: http://testcoders.dev/
Connection: keep-alive

How do I open it?

How do I fix that?

Both are questions which are beyond the scope of the forum here.

1 Like

You’ll have to allow traffic on port 443 just like you’ve already done for port 80. This may involve modifying your firewall config and/or creating a port forward in your router.

Try taking a look at the NGINX docs or searching for a video tutorial :wink:

1 Like

Do I keep port 80 open or close it?

You should keep it open. Again, these questions aren’t related to Cloudflare so don’t really belong here.

2 Likes