The site is not working after adding cloudflare!

When I change the DNS to on the router, the site works for me, but i think it will not work for visitors

Same issue here, the website was working fine, till couple of days ago. Host provider has nothing to do, no response here. and We/ Egypt are keep telling that we will get back to you with no luck!

Any idea if using VPN would help for now? There is work needed to be finished!

I have the same issue
currently, I have disabled the Cloudflare proxy on my websites,until we figure out a better solution

1 Like

Have you tried this? Choose what’s best for you (dns/family/warp)

I have the same problem, I went to the WE technical support centre in Egypt with the same issue, and they connected my rawter there. When I tried it there, the site worked perfectly with Cloudfliare, but when I returned home, it stopped working. I don’t know why, but when I use the Windows command (cmd->ipconfig/flushdns) to make a DNS flush, it works on my laptop but not on my phone. I tried a VPN on my phone, and it worked just fine. I don’t know how to fix this issue without a VPN, but I believe the issue is with a setting on Cloudflare rather than my ISP.

I find out how to fix that your website cannot be reached or doesn’t work when connecting with Cloudflare and works fine when you disconnect Cloudflare, in some countries particularly in Egypt Internet service providers have this issue with Cloudflare, and I want to share how I fix it with who is experiencing this issue, folow the stps
1-Go to your Windows network properties and change the internal IPV4 protocol to Cloudflare IPV4 ( and, then click apply (see screenshots)
2. Go to Google Chrome Settings > Privacy and Security > Use Secure DNS >and choose Custom >then Select from the drop-down box Cloudflare (, do the same from your phone, open any google page from the 3 dots up, go to setting and do the same .
then try your website by laptop and phone it will works fine with Cloudflare.
I hope it is useful.

Same exact problem! My websites do not work on WE ISP, but works on other ISPs. When I change the DNS server on my devices to, it also works normally, and when I turn on “DNS-ONLY” option instead of being proxied, it also works.

I am sure that there it is a problem from the ISP’s end, but I am not sure how to fix this problem for all the other visitors on my website while keeping the websites proxied. I think the ISP needs to fix this error

Same issue here but in my case it takes too long to load files on my websites

Yes I’m having the same issue. The page doesn’t load correctly. The graphics is off and the mp3 files don’t load. When I disable Cloudflare and move the name servers back to the native host the site works perfectly.

Are you saying that your site only partially loads in Egypt?

Bro my site is also not working. Can you give me a solution?

No nothing about Egypt. Just the website didn’t load correctly at all with Cloudflare enabled. I’m trying it again. I turned off URL normalization in page rules… I suppose it could be that because the files were not loading perhaps because the address were being re-written / normalized…

Then this isn’t the same issue. Please don’t hijack other people’s threads.

Excuse me but the title of this thread says: “The site is not working after adding Cloudflare”. If you have nothing nice to say don’t say anything at all.

There are many, many threads with similar titles. Due to many, many different issues.

Yours is not “the same issue,” as it has nothing to with not working in Egypt. The solution for this thread will not work for you, and you are doing yourself and the original poster a disservice by trying to solve a different problem here.

It’s best to start a new post so the Community can assist you with your specific problem there, while continuing to troubleshoot this thread’s issue here.

Has anyone found a solution yet?

Dear all,

I have an odd problem with my website domain “” in Egypt only.

some users can access the website properly and others can’t access the website, they find the message “website can’t be reached”.
some users can access via mobile only but can’t access via laptop, some users find the opposite.
some users can access website via mobile data but can’t by DSL like me now
keep in mind that I’m connecting my domain to Cloudflare.
Outside Egypt, every thing works properly.

my question is: if I change my DNS to open DNS will this problem be solved?

Magdy Galal

See this

any update guys ?? I’m still having same issue with my website

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.