The second page doesn't appear in my site after link it to cloudflare


#1

Hello every one ,
Please help me … After I linked my site to cloudflare … I faced a problem : When I click on ( load more videos ) in the button of my site … it doesn’t load !! So the second page can’t appear !

My site : valuetube.tk

Please tell me how can I fix this problem
And please excuse me for my poor english

Thanks on advance


#2

Please help me …


#3

If you switch Cloudflare from :orange: to :grey: does the More Videos button work?


#4

Thanks very much for your reply , I tried what you said but the second page still can’t appear !


#5

Across all browsers? Cache purged?


#6

Yes I tried all browsers and also I removed cache from all browsers before try


#7

Update : Now the second page is appeared !!
Thanks very much :slight_smile: So now will I switch on cloudflare ?


#9

Yes across all browsers and cache purged


#10

So now will I switch on cloudflare ?


#12

You can try that, and if the issue returns you know it’s related to Cloudflare. If that’s the case I would recommend submitting your details in an email to support AT cloudflare DOT com from your account email address. They should be able to advise if someone here doesn’t have any recommendations.


#13

The problem is you turned on HTTPS in Cloudflare - but the “Load more videos” tries to load the content via HTTP. You must change the code for that button in your site to use HTTPS, maybe it is a plugin or something?

Press F12 in chrome before pressing the button and you will see:

> Mixed Content: The page at 'https://www.valuetube.tk/' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'http://www.valuetube.tk/search?updated-max=2017-12-16T23:00:00-08:00&max-results=13'. This request has been blocked; the content must be served over HTTPS.


#14

Thanks very much for your solution :+1: , But please can you tell me How can I change the code ? or give me an alternative code … because I really don’t understand anything in codes !
And I will be really grateful to you :blush:
Thanks very much again for your help :slightly_smiling_face:


#15

I do not know wordpress, just found the error in Chrome. Mayby you can ask where you got the video plugin?

And also something to try: Set “Automatic HTTPS Rewrites” to ON in the “Crypto” tab here on the Cloudflare dashboard.


#16

WAO detective good finding… just as the switching off cloudflare option to allow troubleshooting but yours is more precise since if switching the cloudflare off will have loaded the videos but will have not point out what you just mentioned. Thanks DUM DUM READING AND LEARNING FROM THE PROS!! wheeww I need a tylenol!!!