The problem of redirecting from Cloudflare to a malicious link

The problem of redirecting from Cloudflare to a malicious link

When I try to open any of my sites linked to Cloudflare,
I am directed to the following link Privacy error

How can I solve the problem

May I ask you to post and share the URL example to the particular resource in a bracketed dot [.] notation with us so we could double-check, troubleshoot and provide some feedback information reagarding the HTTP headers? :thinking:

I wonder if you have some malicious code or malware script on your Website which might result into this :thinking:

I am afraid Cloudflare isn’t involved into this.

However, may I ask if this behaviour continues even when Cloudflare is in “Pause” mode for your domain? :thinking:

You could also determine if this behaviour continues even by using a “Pause” option at Cloudfalre as follows:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect
  4. Make sure site is working as expected with HTTPS.
  5. Retry and make sure you’ve got the expected HTTP response and Website
  6. Upon success, un-pause

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

If there are no Page Rules or Cloudflare Apps being configured, it should be either:

  1. Malicious code on your Website
  2. Some other issue not related to the Cloudflare
2 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.