The page isn’t redirecting properly

Last night my website setup on cloud fare and set rules but at morning i see following error

The page isn’t redirecting properly

An error occurred during a connection to shafiulweb.com.
This problem can sometimes be caused by disabling or refusing to accept cookies.
Any body can help give a solution how i resolve thsi issue.

how I resolve now?

Read the Community Tip I linked to above, and try the 4 quick fixes mentioned at the top of the article.

I would check that SSL Mode is Full (or Full - Strict) on the dashboard: https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls

Then you should check that “Always Use HTTPS” is enabled, https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls/edge-certificates

If the solutions in the tip do not work, come back here with detailed info about the problem, and somebody might be able to help you further.

There is something different there now. It looks like you are redirecting from www to non-www and back. Review your Page Rules. Do you have a rule for Forwarding?

yes,

URL/Description

1 https://shafiulweb.com/

Forwarding URL (Status Code: 301 - Permanent Redirect, Url: https://www.shafiulweb.com) On

Off

2 http://shafiulweb.com/*

Forwarding URL (Status Code: 301 - Permanent Redirect, Url: https://shafiulweb.com/) On

Off

3 http://www.shafiulweb.com/

Forwarding URL (Status Code: 301 - Permanent Redirect, Url: https://www.shafiulweb.com) On

Off

any wrong here?

Wrong anything here?

You also have a redirect on your Origin Apache server sending www back to non-www.

Either disable the redirect on your origin, or reverse the first page rule to match it.

Page rules 2 and 3 are redundant if your have enabled “Always Use HTTPS”.

curl https://www.shafiulweb.com. -v
< HTTP/2 302
< location: https://shafiulweb.com/
<
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>302 Found</title>
</head><body>
<h1>Found</h1>
<p>The document has moved <a href="https://shafiulweb.com/">here</a>.</p>
<hr>
<address>Apache Server at www.shafiulweb.com Port 80</address>
</body></html>

not clearly understand What can I do?

Your Cloudflare rules are saying: website is at www.example.com
Your Apache rule is saying: website is at example.com.

These both cannot be true. You are redirecting from one to the other, and eventually the browser gives up. This is a “Redirect Loop”.

Try disabling the First Page rule (just click the green slider you see in your image above) and see if that resolves the issue.

if i delete page rule my site will open

@ this moment

but still not open site

If you read the first article I linked to you will find the answers.

Right now you have SSL Mode set to Flexible, quick fix 4 in the article says to try enabling Full (https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls)

Full (strict)

Encrypts end-to-end, but requires a trusted CA or Cloudflare Origin CA certificate on the serve

image which one select