The page error when turn on "Proxied" option

Hi, is there something wrong currently with turning on “Proxied” option?

  1. we already point canary.kodadot.xyz to main.nft-gallery-5ci.pages.dev. but the page is different. there is no cart icon, and the line above Spotlight is different. I suspect that canary.kodadot.xyz is still cached in the wrong version

  2. I added another subdomain to test it out. But, the page returns 522. It says, “Please contact your hosting provider”. Meanwhile, our hosting provider is Cloudflare Pages :sweat_smile:

uugghh, I can’t embed media. details here https://github.com/kodadot/nft-gallery/issues/6697#issuecomment-1676441337

Did you try purging the cache?

Did you add it to the Pages dashboard?

not yet, let me try

yes

What’s the subdomain?
another-canary.kodadot.xyz (from the issue) doesn’t look like it was

yes this one

and we have another one, ’ canary.kodadot.xyz. but, if I turn on the "Proxied" feature, it will show blank page. return wrong version of the page. we already point canarytomain.nft-gallery-5ci.pages.dev`

and point another-canary to 82e0ff71.nft-gallery-5ci.pages.dev

Yeah purge that and see if it’s resolved. Since it’s failing with proxied on, that means it’s something in the zone config. “Old version” definitely points to zone cache.

another-canary will need to be added to the Pages dashboard under Custom Domains to serve content.
You also shouldn’t point to an individual deployment in your DNS

already press the “Purge Everything” button, still the same results

ok, I will test it again with another name

uugghh, actually I want to set a specific subdomain to branch/deployment

with this, I only can set it to the main DNS

You can edit afterwards. It needs to be added to Pages though or we can’t route it.

now, it shows a blank page. this is what we got in canary before when I turned on “Proxied”. I already point another-canary to 82e0ff71.nft-gallery-5ci.pages.dev


.

Did you unproxy? It seems to be working for me right now


If you did, can you re-proxy so I can see?

could you try press Ctrl/Cmd + Shift + R several times and see what happens

After a few it did it, looks like some JS error:


I’d maybe try turning off any JS and HTML minification if you have those enabled: Auto Minify · Cloudflare Speed docs

ok, let me try

thanks, it works now

will try to turn on proxied in canary again

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.