The menu is not working

I had a problem , when we use the Cloudflare, out website’s home page menu can not working in mobile , when we stop the Cloudflare, using our oringial server , it is working in mobile. we tested many time , but we can not found what is problem , would you please let me , thanks .

Now we enable the Cloudflare for your checking.

gflai.com.mx

it is working ,when we stop to use Cloudflare

Might be the “Rocket Loader” feature. Could you try to disable it and see if anything different? :thinking:

Navigate to the Cloudflare dashboard → Speed → Optimization → Scroll down to find section “Rocket Loader” and toggle it off (grey).

Therefore, I can see you’re using WordPress and Elementor.
Kindly, see below article which is realted to the Rocket Loader from my suggestion:

Also, try to disable the “Auto Minify” feature for HTML, CSS and JS, just in case :thinking:

2 Likes

Dear Fritex,

Thank you so much for your help.

Yes, we toggle it off for the rocket loader, it is working now, it seems that everythins is ok.

Also for the elementor, we use the template, but i do not understand how to do this :slight_smile:

  • For Elementor templates: Site URL/?elementor_library=*

How to setup up it in Cloudflare, thanks again.

Tim

Awesome! Thank you for feedback information :blush:

If you’ve followed my first suggestion, you’ve successfully disabled Rocket Loader for your whole domain :+1:

In the article I mentioned, the Elementor is saying you can keep Rocket Loader enabled for your domain, however, if it causes some issues - as it is in your case - you can explicitly disable it on a specific URLs only by using Cloudflare Page Rules.

Nevertheless, you might not need to use them now as 1st suggestion disables it in general.

Otherwise, if you’d like to try and use Cloudflare Page Rules, kindly, navigate to the Cloudflare dashboard → Rules → Page Rules.
Click on the blue button saying “Create Page Rule” to create it.
For the 1st rule:

  1. You’d be entering gflai.com.mx/?elementor_library=*
  2. Selecting the option “Rocket Loader” from the dropdown menu
  3. Click on the toggle button next to it to make sure it’s set on “Off” (grey color).
  4. Click on the blue button “Save and Deploy Page Rule”.

The same steps for the 2nd rule they’re stating about, just you’d be entering gflai.com.mx/*elementor* and repeat the steps from above.

In picture (NOTICE: Make sure the toggle button is set to grey - not green):

Helpful articles:

Dear Fritex,

Got it and thank you so much for your help. have a nice day…

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.