The main page of my website does not show the latest posts

the main page of my website is not updated automatically in chrome/firefox when I publish new posts. I must press f5 each time I publish something to show the most recent articles.

I think it has to do with the browser cache and cloudflare. it is as if cloudflare does not detect the changes or does not indicate the changes to the browser and this therefore shows an old version of the site stored locally

in cloudflare I have activated the option “Automatic Cache Management: Purge Cloudflare cache automatically when you update the appearance of your site”.

I use litespeed and autoptimize, but even when I completely disable them the problem continues.

if it helps, I analyzed the headers section of my site with an online tool, and reported this


200 OK

Status: 200 OK
Code: 200
Date: Thu, 31 Oct 2019 22:56:13 GMT
Content-Type: text/html; charset=UTF-8
Connection: close
Set-Cookie: __cfduid=d10c90c6c72ddbcf4663bc49a1d0130411572562573; expires=Fri, 30-Oct-20 22:56:13 GMT; path=/; domain=.tecnobits xyz; HttpOnly; Secure
Cache-Control: public, max-age=2592000
Cf-Railgun: direct (starting new WAN connection)
Expires: Sat, 30 Nov 2019 22:26:24 GMT
Link: <https://>; rel=shortlink
Vary: Accept-Encoding
X-Litespeed-Cache: hit
X-Powered-By: PHP/7.0.33
X-Turbo-Charged-By: LiteSpeed
CF-Cache-Status: DYNAMIC
Expect-CT: max-age=604800, report-uri=“https://
Server: cloudflare
CF-RAY: 52e938918d8dce57-LHR

It’s a caching “problem”, your website looks to be cached by Litespeed, try searching the site from an incognito tab or remove caching, load the site, and add caching back

1 Like

More in detail:
purging cache from cloudflare will not work as Litespeed is caching. So, to solve, remove cache from Litespeed and then purge cloudflare cache, or temporarily put your site into development mode. If you constantly update your site (eg. every hour), set your Cache-Control header accordingly to renew the cache every hour or two. You should add that setting via cloudflare and Litespeed to assure they do not affect each other

This topic was automatically closed after 30 days. New replies are no longer allowed.