The google search result URL can not be Open

hi

My websites is sunshinegaskets(.com), when I search my products: Rubber-steel Gasket with an Internal O-rings, it shows on google results page. The browser is Google Chrome, But when I click it, the url can not be open

And when I use other browser, and click it the URL, the URL can be open.

So what is the problem, should I close Signed Exchanges Service? I can not write URL here, you can google it and find it

Waiting for your reply.

Visiting your website from these search results works fine for me:


I tried in both Mozilla Firefox and Google Chrome

Can you tell more about the URL that’s failing, and are these being accessed from a mobile browser or desktop? Can you show what the error is?

When you say it worked in a different browser, do you know if it could be caused by your browser cache? Does trying Google Chrome on a different device or network work?

Hello Erisa

But you can not open by Google Chrome, as the URL changes another URL, by other brower it is right URL and can be open

Hi

Pls check

The webpkgcache domain is used for Signed Exchanges. Not sure why they are breaking your site, but you could try turning off Automatic Signed Exchanges in the Cloudflare Dashboard temporarily while you sort this issue out?

Likely I would imagine their network/environment is blocking those webpkgcache URLs for whatever reason?

1 Like

hi

I do not know, just chrome can not open

Hi

Will have a try

What other browser did you try? It’s possible that Chrome is the only browser supporting signed exchanges so using something like Firefox would not use them.

Regardless, all these links work fine for me on Google Chrome, which hints that it may be an environment issue relative to you.

I would recommend disabling Signed Exchanges for now, since they are apparently causing issues.

Hi

Yes, I will stop it anyway

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.