The Edge Certificate is stuck on Pendind Validation

Answer these questions to help the Community help you with Security questions.

What is the domain name?
thecloudkeys.rentals

Have you searched for an answer?
Yes, but none worked for me.

Please share your search results url:
https://www.google.com/search?q=Cloudflare%27s+universal+edge+ssl+stuck+on+pending&sca_esv=563701320&sxsrf=AB5stBgkxDyqRtuSRbME1CgstU5_xJcRvA%3A1694172582418&ei=pgX7ZJz4GKOA9u8Puoy58A8&ved=0ahUKEwic49nX9JqBAxUjgP0HHTpGDv4Q4dUDCA8&uact=5&oq=Cloudflare%27s+universal+edge+ssl+stuck+on+pending&gs_lp=Egxnd3Mtd2l6LXNlcnAiMENsb3VkZmxhcmUncyB1bml2ZXJzYWwgZWRnZSBzc2wgc3R1Y2sgb24gcGVuZGluZzIFEAAYogQyBRAAGKIEMgUQABiiBEiiMVC3BljeH3ACeAGQAQCYAccBoAH_EKoBBDAuMTS4AQPIAQD4AQHCAgoQABhHGNYEGLADwgIHECMYsAIYJ8ICCBAAGIkFGKIE4gMEGAAgQYgGAZAGBg&sclient=gws-wiz-serp

When you tested your domain, what were the results?
I got an error on the chrome browser: “ERR_ssl_version_or_cipher_mismatch” and could not access the domain. Now I have temporarily paused the site on Cloudflare, until I find a solution

Describe the issue you are having:
Under the Edge Certificates, the certificate is not issued and the status is set to “Pending Validation” for over 24+ hours.

What error message or number are you receiving?
ERR_ssl_version_or_cipher_mismatch on browsers

What steps have you taken to resolve the issue?

  1. I have enabled and disabled the Universal SSL. As suggested in some other posts, I have waited for 5 minutes before enabling it.
  2. I could not find the curl methods to check the digest certificates

Was the site working with SSL prior to adding it to Cloudflare?
Yes. I have let’s encrypt on the server and it was working as expected.

What are the steps to reproduce the error:

Have you tried from another browser and/or incognito mode?
Yes but still the problem is there. I have paused the domain from using Cloudflare at the moment.
Please attach a screenshot of the error:
image|690x320

Were you able to resolve this @vgkouvelou?

@cloonan
Unfortunately, no. I have paused the site on Cloudflare and the certificate is still pending validation. If I unpause the site, then I will face the problem described above. I use Let’s Encrypt’s SSL on the server, and everything is set up properly. Still, the error persists on Cloudflare’s side.

1 Like

Thank you, sorry for the issues. Can you please reach out to Support in an account ticket? They can directly interact with your account and further investigate why the Edge Certificate is stuck in “Pending Validation”.

To create an account ticket, go here https://dash.cloudflare.com/?to=/:account/support and please share your ticket number here so that we can flag it for the team to follow-up.

Thank you for the response. Here is the Ticket ID: 2930720.

Is cloudflare paused or unpaused now? Site loads fine for me.

@cloonan

Cloudflare is currently paused. I can not unpause it, as it is a live site and it will create a problem to the client. Also mentioned that when i first posted here, in order to avoid any misunderstandings.

I still experience the problem and there is no reply to my ticket or anywhere else.
The only answer I got was an automated one. Is there any solution to the problem that exists on the end of Cloudflare? Because I can not do anything on my end at the time. Or there are no Guidelines or workarounds for that.

Hello @cloonan,

It seems that the Universal SSL tried to use a Google Service as a Certificate Authority. And it just got stuck there. Even if Cloudflare uses Let’s Encrypt for USSL it stills remains in the pending state, until timeout. As this is not a problem on our end, is it possible to collaborate more on the situation with the Universal Certificates or Named Edge Certificates?