The connection for this site is not secure

Hi there,
Recently after a year, I came back to Cloudflare but after setting the name servers and active CDN and SSL my website and my weblog, not lunch anymore.


I read lots of the article in the help center and set a Cloudflare origin certificate on my Cpanel host but noting the change and I can’t lunch my website over full strict SSL or other protocols.

as you see in the below picture I set the Origin Certificate on my host but nothing happened!
Screenshot 2020-12-16 000504

my website: iHMahmoodi.ir
My weblog: blog.ihmahmoodi.ir

Neither of those are proxied by Cloudflare. The good news is that you have a Let’s Encrypt certificate on your server. And I’m not seeing a “not secure” message right now.

1 Like

You didn’t see that because I thought you reply too late, so I change the Cloudflare settings to normal to get back my website online.

but now it’s as before.
my website is proxied through Cloudflare and the certificates are set again on my host, so you have to get a “not secure” message again.

It looks like there’s just no certificate. In the SSL/TLS -> Overview section, what’s your SSL setting? You did say “Full (Strict)”, but I’d like to confirm.

And then check the Edge Certificates section to see if you have an active certificate.

this is my SSL status on my Cpanel after install CloudFlare Origin Certificate.

and this is in my CloudFlare

I don’t know how to active this Edge Certification on my host.

Ah, it’s “Pending Validation”, so it’s not ready yet.

You may have to try again:

  1. Go to the bottom of the Edge Certificates Screen
  2. Click on “Disable Universal SSL”
  3. Wait 5 minutes for it to completely reset
  4. Click on the same button to Enable Universal SSL.

It should activate quickly. If it takes more than 15 minutes, then open a Support Ticket and let them know it was stuck on “Pending Validation” and you’ve tried to reset it.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

It’s Pending for 2 days! and I did this before (reset/active).
unfortunately, the help center and ticketing are stuck on diagnostics windows and not go to the next level.

Try sending an email to: support AT cloudflare DOT com from the email address associated with your account. You should get a reply with a ticket number. Post that number in a reply here.

Your request (#2045634) has been submitted and a Technical Support Engineer will be contacting you soon

1 Like

my website / weblog is down for 2 days, would you help me faster to solve this weird problem?

When @cloonan gets in to work tomorrow (starting about ten hours from now), he’ll most likely check on the ticket status.

could I turn the settings back to make my website online for now?

update: for now I restore my host certificate to Let’s encrypt to enable my website temporary until you co-worker fix that Edge certificate from CloudFlare side.

There is no answer(fixing the problem) yet.
@cloonan @sdayman

Hi @ihmahmoodi, I suspect either www.example.com or example.com is not orange-clouded. Click :ngrey: to change to :orange: on the www and A record in the DNS app of your cloudflare dashboard.

For the Cloudflare Universal SSL certificate to be provisioned, you must orange-cloud any required records. Once the DNS record has been orange-clouded, your Cloudflare Universal SSL certificate will start to be provisioned. Further information about how to do this can be found on the quick setup guide, Cloudflare Quick Setup Guide.

Hi @cloonan ,
OK, it’s back to orange-cloud and proxied right now.

1 Like

@cloonan would you please fix this in the first place, I have lots of work that all depend on my weblog.
I appreciate it!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.