The connection for this site is not secure - I tried all solutions in Cloudflare community

Screenshot 2022-01-29 161035

I am having this trouble. I can access my website with http:// but https://
I tried all mixed content error solutions but not successful.
Please help me.

This is a case of Cloudflare not being able to communicate with your website securely.

What happened?

Cloudflare is unable to establish an SSL connection to the origin server.

What can I do?

If you’re the owner of this website:

It appears that the SSL configuration used is not compatible with Cloudflare. This could happen for a several reasons, including no shared cipher suites. Additional troubleshooting information here.

Have you tried reading the linked support page?

Was your site secure before you added it to Cloudflare?

1 Like

No it was not. I got my domain, direct NS to the hosting, then installed Wordpress and then install Cloudflare as normal. However it did not work even Couldflare say “Active”.

As you saw in the Mixed Content tip, #4, using Flexible SSL is most often the culprit.

And the reply from @user21517 above confirms the issue.

Here’s more on the issue:

Bottom line is that if having a secure site is important to you, you will secure it at the origin. I suggest you use the “Pause Cloudflare on Site” option from the Overview tab for your domain at The link is in the lower right corner of that page. Give it five minutes to take effect, then make sure site is working as expected with HTTPS. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

1 Like

I do not know what the problem is exactly so I have not tried yet. But according to what you said, the problem might comes from my hosting.

“make sure site is working as expected with HTTPS”
I do not understand this part. What does this mean?

That’s exactly it.

If you want HTTPS, your host should configure this from the get-go. Please don’t add an insecure site to Cloudflare and expect it to become secure, because it won’t be.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.