The Cloudflare domain is not bound to an AWS EC2 instance

I have a Cloudflare domain, hexpay.io, and an AWS EC2 instance with an Nginx server installed. I’ve tried a lot of different combinations of DNS records, Nginx configurations, and TLS settings, but I still haven’t seen my site on my domain.

Cloudflare

  • I’ve tried different DNS Records settings:
type name content Proxy TTL
A @ 3.122.92.181 true/false Auto/1 min
A www 3.122.92.181 true/false Auto/1 min
type name content Proxy TTL
CNAME @ ec2-3-122-92-181.eu-central-1.compute.amazonaws.com true/false Auto/1 min
CNAME www ec2-3-122-92-181.eu-central-1.compute.amazonaws.com true/false Auto/1 min
  • It’s interesting that when I enable Cloudflare proxying, I see this message: ‘This hostname is not covered by a certificate.’
  • TLS Settings (Cloudflare Origin Server Certificate installed):
    • Off
    • Flexible
    • Full
    • Full (Strict)

AWS

  • Public IPv4 DNS: ec2-3-122-92-181.eu-central-1.compute.amazonaws.com
  • Public IPv4 address (Associated Elastic IP): 3.122.92.181
  • Security groups: 443/80 ports opened for all IPv4

Server

  • Cloudflare Origin Server Certificate installed
  • Nginx config:
server {
    listen              443 ssl http2;
    listen              [::]:443 ssl http2;

    server_name hexpay.io www.hexpay.io;

    ssl_certificate /etc/ssl/certs/cf.pem;
    ssl_certificate_key /etc/ssl/private/cf.pem;

    location / {
        proxy_pass http://localhost:8080;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "Upgrade";
        proxy_set_header Host            $host;
        proxy_set_header X-Real-IP       $proxy_protocol_addr;
        proxy_set_header X-Forwarded-For $proxy_protocol_addr;
        proxy_read_timeout 600s;
    }
}

server {
    listen 80;
    listen [::]:80;

    server_name hexpay.io www.hexpay.io;

    location / {
        return 302 https://$host$request_uri;
    }
}

That domain is not registered yet.

1 Like

What do you mean?

You may have added the domain to Cloudflare, but it seems you haven’t bought it yet:

1 Like

I believe Cloudflare registered it for me when I bought it…

Did you actually buy the domain via Cloudflare?

If so, please check under https://dash.cloudflare.com/?to=/:account/domains

1 Like

I believe I may have confused Domain Registration with Domain Protection in the Cloudflare interface. I see this on the Manage Domains page, and a blank page on the Register Domain page.

Why I can’t register new domain name?

Did you verify your email address already?

If the answer is yes, you might want to try in a different browser or in a private window with extensions disabled.

Yes, I’ve already verified my email address. Same thing using Guest Chrome user

I just found a receipt in the Billing History indicating ‘Domain Registration.’ However, I’m not seeing my domain on the Manage Domains page. Could you please help me understand why? Invoice status is “Paid”

I’m afraid I (or the community in general) cannot help with that. You should open a support ticket of type “Cloudflare Registrar” here:
https://dash.cloudflare.com/?to=/:account/support

When describing your problem, you should definitely include that the domain seems to still be available for registration.

If you share your ticket’s number here after you created it, I can bring that to the attention of Cloudflare support.

1 Like

I understand. Here is my ticket number: 3038840, anyway thank you

2 Likes

Just another idea:

How much did you pay? Was it for a domain or a Cloudflare plan?

1 Like

Invoice says: ‘Domain Registration’

Curious. I’ve escalated the ticket to CF support.

1 Like

Marta confirmed earlier today on 3038840 that it’s been sent to the appropriate team, and they’ll need to work with you, I can no longer see your ticket, only the T&S team can now at this time. Please wait for them to reach out to you to remedy this. Sorry for the delay we appreciate your patience.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.