The changes i am made through wordpress are not reflecting in the live site

cache

#1

Hi,
i have domain gharstuff.com which is active on cloudflare.com but from last some weeks i am facing issue that the change i made are not reflecting.
After so much emails and spending time with hostgator (from where to my hosting belongs). they replied me saying that the issue is from cloudflare cache.

I already paused cloudflare from my site almost 36 hours ago but i am still facing the same issue.
here i am showing you the reply i got from hostgator.

Hello,

We have reviewed the issue as the updates were not being reflected on a different browser or when admin is logged out.

Hence we updated product maggi-masala-noodles unit 70 mg with (Pack of 1), it is not reflecting after log out of admin. Refer: https://i.imgur.com/38sTjrt.png . Then we accessed the same URL using our temp URL Https://gharstuff.com.md-in-79.hostgatorwebservers.com . It is reflecting on the same. Refer:https://i.imgur.com/pXGmjuQ.png . Please note the URL in both screenshots. With this it is clear the the issue is with the cache at cloudflare. You can also refer the below curl result:

====================
$ curl https://gharstuff.com/product/maggi-masala-noodles/ | grep “70 gm”
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0<div>70 gm</div>

$ curl https://gharstuff.com.md-in-79.hostgatorwebservers.com/product/maggi-masala-noodles/ | grep “70 gm”
0 0 0 0 0 0 0 0 --:–:-- 0:00:01 --:–:-- 0<div>70 gm (Pack of 1)</div>

Further, We have added a host file entry for your domain to bypass cloudflare and request to directly served from the server. On doing this we could see that the changes immediately reflecting on all browsers.(We have done this on a different product just to be sure). Please refer the below screenshot:https://i.imgur.com/fnGOyod.png

With this, it is evident that the issue faced by you is due to the cloudflare and its caching.

I don’t know what to say about that and i am confused.
Anybody please advise me what i should do and what should be my next step.

Thank you, any help will be appreciated.


#2

You server seems to send “Cache-Control: max-age=0” - at least for the URLs https://gharstuff.com.md-in-79.hostgatorwebservers.com/product/maggi-masala-noodles/ and https://gharstuff.com/product/maggi-masala-noodles/ - as such - no caching at all should happen on Cloudflare’s side IMHO, unless you’ve done something like going to Firewall rules and asked for pages to be “Cache everything” or something like that (and if so, Cloudflare is just doing what you asked). Is there any chance you have such firewall rules?

By the way, with max-age=0 that basically means Cloudflare has to go to your server every single time… which means that things do get updated immediately on one hand, but performance is affected on the other hand.


#3

No there is nothing like firewall rules i know about.
As i don’t know how this happens, so i am not 100% sure.

Can you advise me where i can find this option.

Thank you


#4

Firewall rules are under the “Firewall” tab…


#5

No there is not any rule defined right now


#6

Then I’m surprised to hear of a cache from Cloudflare’s side :open_mouth:

Maybe someone else will have an idea. Otherwise, support ticket…


#7

Raised one, let see what they will say. Btw i am so tired of sending and receiving lots of mails from both sides (cloudflare and hostgator specially) from last 2-3 weeks.

Well, thanks for coming out for the help.

I appreciate, thank you


#8

I believe @shimi meant to refer to “cache everything” which is a setting available if you create a page rule, under tab Page Rules (and not Firewall Rules).


#9

I haven’t created any page rule too.


#10

Currently your domain is not behind Cloudflare, the connection is going direct to origin and is not returning the value either. Please compare the two curl request headers below (notice for example the woocommerce cookies which exist in the second response but not in the first). This is an issue on the local server.

curl -Ikv https://gharstuff.com/product/maggi-masala-noodles/

  • Trying 43.225.55.182…
  • TCP_NODELAY set
  • Connected to gharstuff.com (43.225.55.182) port 443 (#0)
  • ALPN, offering h2
  • ALPN, offering http/1.1
  • Cipher selection: ALL:!EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH
  • successfully set certificate verify locations:
  • CAfile: /usr/local/etc/openssl/cert.pem
    CApath: /usr/local/etc/openssl/certs
  • TLSv1.2 (OUT), TLS header, Certificate Status (22):
  • TLSv1.2 (OUT), TLS handshake, Client hello (1):
  • TLSv1.2 (IN), TLS handshake, Server hello (2):
  • TLSv1.2 (IN), TLS handshake, Certificate (11):
  • TLSv1.2 (IN), TLS handshake, Server key exchange (12):
  • TLSv1.2 (IN), TLS handshake, Server finished (14):
  • TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
  • TLSv1.2 (OUT), TLS change cipher, Change cipher spec (1):
  • TLSv1.2 (OUT), TLS handshake, Finished (20):
  • TLSv1.2 (IN), TLS change cipher, Change cipher spec (1):
  • TLSv1.2 (IN), TLS handshake, Finished (20):
  • SSL connection using TLSv1.2 / ECDHE-RSA-AES128-GCM-SHA256
  • ALPN, server accepted to use h2
  • Server certificate:
  • subject: CN=gharstuff.com
  • start date: Jan 18 21:05:47 2019 GMT
  • expire date: Apr 18 21:05:47 2019 GMT
  • issuer: C=US; O=Let’s Encrypt; CN=Let’s Encrypt Authority X3
  • SSL certificate verify ok.
  • Using HTTP2, server supports multi-use
  • Connection state changed (HTTP/2 confirmed)
  • Copying HTTP/2 data in stream buffer to connection buffer after upgrade: len=0
  • Using Stream ID: 1 (easy handle 0x7f8a3d000c00)

HEAD /product/maggi-masala-noodles/ HTTP/2
Host: gharstuff.com
User-Agent: curl/7.62.0
Accept: /

  • Connection state changed (MAX_CONCURRENT_STREAMS == 100)!
    < HTTP/2 200
    HTTP/2 200
    < date: Mon, 04 Feb 2019 16:06:41 GMT
    date: Mon, 04 Feb 2019 16:06:41 GMT
    < server: Apache/2.4.37 (cPanel) OpenSSL/1.0.2q mod_bwlimited/1.4 Phusion_Passenger/5.3.7
    server: Apache/2.4.37 (cPanel) OpenSSL/1.0.2q mod_bwlimited/1.4 Phusion_Passenger/5.3.7
    < last-modified: Wed, 05 Dec 2018 19:48:24 GMT
    last-modified: Wed, 05 Dec 2018 19:48:24 GMT
    < accept-ranges: none
    accept-ranges: none
    < cache-control: max-age=0
    cache-control: max-age=0
    < expires: Mon, 04 Feb 2019 16:06:41 GMT
    expires: Mon, 04 Feb 2019 16:06:41 GMT
    < vary: Accept-Encoding
    vary: Accept-Encoding
    < content-length: 95622
    content-length: 95622
    < content-type: text/html
    content-type: text/html

curl -Ikv https://gharstuff.com.md-in-79.hostgatorwebservers.com/product/maggi-masala-noodles/

  • Trying 43.225.55.182…
  • TCP_NODELAY set
  • Connected to gharstuff.com.md-in-79.hostgatorwebservers.com (43.225.55.182) port 443 (#0)
  • ALPN, offering h2
  • ALPN, offering http/1.1
  • Cipher selection: ALL:!EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH
  • successfully set certificate verify locations:
  • CAfile: /usr/local/etc/openssl/cert.pem
    CApath: /usr/local/etc/openssl/certs
  • TLSv1.2 (OUT), TLS header, Certificate Status (22):
  • TLSv1.2 (OUT), TLS handshake, Client hello (1):
  • TLSv1.2 (IN), TLS handshake, Server hello (2):
  • TLSv1.2 (IN), TLS handshake, Certificate (11):
  • TLSv1.2 (IN), TLS handshake, Server key exchange (12):
  • TLSv1.2 (IN), TLS handshake, Server finished (14):
  • TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
  • TLSv1.2 (OUT), TLS change cipher, Change cipher spec (1):
  • TLSv1.2 (OUT), TLS handshake, Finished (20):
  • TLSv1.2 (IN), TLS change cipher, Change cipher spec (1):
  • TLSv1.2 (IN), TLS handshake, Finished (20):
  • SSL connection using TLSv1.2 / ECDHE-RSA-AES128-GCM-SHA256
  • ALPN, server accepted to use h2
  • Server certificate:
  • subject: CN=gharstuff.com
  • start date: Jan 18 21:05:47 2019 GMT
  • expire date: Apr 18 21:05:47 2019 GMT
  • issuer: C=US; O=Let’s Encrypt; CN=Let’s Encrypt Authority X3
  • SSL certificate verify ok.
  • Using HTTP2, server supports multi-use
  • Connection state changed (HTTP/2 confirmed)
  • Copying HTTP/2 data in stream buffer to connection buffer after upgrade: len=0
  • Using Stream ID: 1 (easy handle 0x7fb2dc809400)

HEAD /product/maggi-masala-noodles/ HTTP/2
Host: gharstuff.com.md-in-79.hostgatorwebservers.com
User-Agent: curl/7.62.0
Accept: /

  • Connection state changed (MAX_CONCURRENT_STREAMS == 100)!
    < HTTP/2 200
    HTTP/2 200
    < date: Mon, 04 Feb 2019 16:11:45 GMT
    date: Mon, 04 Feb 2019 16:11:45 GMT
    < server: Apache/2.4.37 (cPanel) OpenSSL/1.0.2q mod_bwlimited/1.4 Phusion_Passenger/5.3.7
    server: Apache/2.4.37 (cPanel) OpenSSL/1.0.2q mod_bwlimited/1.4 Phusion_Passenger/5.3.7
    < x-powered-by: PHP/5.4.45
    x-powered-by: PHP/5.4.45
    < link: https://gharstuff.com/wp-json/; rel=“https://api.w.org/”, https://gharstuff.com/?p=1956; rel=shortlink
    link: https://gharstuff.com/wp-json/; rel=“https://api.w.org/”, https://gharstuff.com/?p=1956; rel=shortlink
    < set-cookie: woocommerce_recently_viewed=1956; path=/
    set-cookie: woocommerce_recently_viewed=1956; path=/
    < cache-control: max-age=0
    cache-control: max-age=0
    < expires: Mon, 04 Feb 2019 16:11:45 GMT
    expires: Mon, 04 Feb 2019 16:11:45 GMT
    < content-type: text/html; charset=UTF-8
    content-type: text/html; charset=UTF-8

#11

This is quite difficult to understand for me. In short you mean the domain is not going through cloudflare and the issue is from hostgator side.

Well thanks for this deep detailing, i will send these details to the hostgator support through a ticket and let see what they will say. They are continously saying that issue is from cloudflare side even when i have paused my site on cloudflare.

Once again thank you so much.


#12

Don’t want to open separated topic for asking 1 simple question and that’s why decided to ask here - how can I turn off entire caching, since I already have a cache plugin installed on my gaming website there, having them both turning on puts the website in trouble - I can’t update the website when it’s files has changed even while clearing cache from both sides (WP and CF), so please tell me how can I turn CF caching off thanks!


#13

guys, can this issue is resolved by a new wordpress installation with a backup and restore plugin or something else.

may be there is a problem with my wordpress, is there any chance of that ?

There is one more thing which is confusing me please refer the image below, why cloudflare still say caching