The address does not open without www


#1

Good day. I transferred the domain to cloudflare. Now when I call 3points.xyz in the browser line, I get the error https://cloud.3points.xyz/8621511a123a Although when I add www.3points.xyz, the page loads instantly. Please indicate what you need to include in the setting so that when writing in the browser 3points.xyz the site opens. Thanks in advance for your reply.


#2

Are your DNS records for both addresses identical?


#3

Here are the current dns settings https://cloud.3points.xyz/2aee9aa39797. The Hostin provider says that everything works for them regularly even sent a video https://www.useloom.com/share/33937935aa964887b1bad1e238779c72. But when I call 3points.xyz I get 522 error https://cloud.3points.xyz/4399bfda7cbb. Please tell me how to make it so that when you call 3points.xyz the site opens? Thanks in advance for your reply.


#4

Well, the records are not identical.

The naked domain points to an IP address whereas the www record is a CNAME. Is that 174 address correct at all? The video is pretty pointless I am afraid as it shows us something we already know.


#5

I bought a domain name on reg ru registered there dns from cloud flare. The hosting is located on the designer of the landing pages landingi.com. I did follow the instructions for connecting cname http://support.landingi.com/english/landing-page-with-wildcard-lets-encrypt-ssl. The address https://www.3points.xyz/ and 3points.xyz ran open when dns were on reg.ru, but since Russia is blocking on amazon, users could not get to my website. I decided to connect to cloudflare. But after connecting to this address 3points.xyz, all users will get an error 522. The saddest thing is that I like the ball pin pong appeal to you, in ladingi, reg.ru and all send to each other; (Well, this is because of fatigue, I write :slight_smile:
Most often, the user scores in the browser line 3points.xyz and not (https://www.3points.xyz/) because it is shorter. Maybe you can change in your service and register with the name * 3points.xyz.


#6

Well, it is not much of a surprise that one address works while are other does not if they point to different hosts.

In the case of your naked domain it seems your server simply is not configured to respond to HTTPS
http://sitemeer.com/#https://174.129.25.170

You need to contact your host about that.


#7

Alternatively you could also use a page rule to rewrite all naked requests to www, basically rendering your hosting obsolete. Cant tell if that is an option for you.


#8

Good day, Sandro. I asked the hosting question and this is what they said to me.

Hello, and how much you can’t set up a top-level domain and host a WWW subdomain. How do I register 3points.xyz? https://cloud.3points.xyz/2d8a0c089957
Re:
Hello,

3points.xyz is a root domain, we do not recommend publishing a Landing Page on a root domain. If you do so, then landing page will “cover” the existing website – it will stop displaying. Instead, you can redirect a subdomain.

Is it possible to redirect requests from 3points.xyz to www.3points.xyz? Thanks in advance for your reply.


#9

Sure, still with a page rule, just the other way round.


#10

You mean by this manual https://support.cloudflare.com/hc/en-us/articles/200168306-Is-there-a-tutorial-for-Page-Rules-#redirects ?


#11

Also, but basically the same thing we discussed a week ago.


#12

Hi Sandro, I made the settings according to the instructions https://support.cloudflare.com/hc/en-us/articles/200168306-Is-there-a-tutorial-for-Page-Rules-#redirects and then entering 3points.xyz goes Pre-addressing to www.3points.xyz http://cloud.3points.xyz/15e05014bdca? I get the error “The site www.3points.xyz redirected too many times” This is the setting that I made. Can you tell me how to correct this? Thanks in advance for your reply. Now I have temporarily removed the redirect setting so that the site is available at www.3points.xyz.


#13

Can you post a screenshot of the rule?


#14

#15

Remove the first asterisk and append to the forwarded URL /$1.


#16


In this form?


#17

Why did you add a dot?


#18

Because in the instructions with a dot, you wrote that you need to remove the first asterisk.

Can you specify the values ​​that you need to enter in these 2 fields? Thanks in advance


#19

I did write that you should remove the asterisk but there was no dot in the first place :wink:


#20

I removed the first point. now works thank you