Testing out firewall rules for location (country)

Hello,

I had just set the firewall rule to block my current country from accessing my website (I am using Squarespace), but I am not sure if it is working correctly.

I am trying to test out if my firewall rule is working. This is what I did:

  1. I entered my URL and my site still shows.
  2. Using a VPN (I tried connecting to Japan, US, Netherlands) and my site still shows.

If I am right, when I am accessing my site from my current location (which is the country I had set the firewall rule for), my site should not show, correct?

But why is it still showing when I typed in the URL? I’m confused if I need to do anything further or I did something wrong.
(I’ve already changed the nameservers on my Squarespace site. Not sure if it needs a certain time frame for it to come into effect and I am just being impatient)

Another question, I should still be able to access the admin side of my website, correct?

Thank you in advance.
Maureen

Can you post a screenshot of your firewall rule? And if you let us know the domain name, we can test it.

Here is the screenshot :

My website is www.iammaureenfletcher.com

Thank you so much!
Maureen

You domain is using Cloudflare DNS, but the site itself is not proxied by Cloudlfare. Connections are going directly to Squarespace, so any rules or features you enable at Cloudflare will not apply while that site is in :grey: DNS Only mode.

Meaning, my site is still accessable to the country I want to block off, yes?

If that’s the case, is the any additional steps/alternative that I can do to achive my main intention?

Thank you in advance,
Maureen

Correct.

Squarespace doesn’t support a Cloudflare configuration, but your best bet is to set your site’s DNS records to :orange: Proxied.

Is this something that I can do on my Squarespace admin side or do I need to get someone to help me? Or is there a guide/step-by-step tutorial that I can follow?

So sorry for the long winded questions. I’m an end-user and not well versed with technical subjects.

Thank you!
Maureen

You should see the records on your DNS page. There are four of them that begin with a 198. And they have a :grey: after them. You’ll need to click on each one to edit, then click on the :grey: to toggle it to :orange: then save.

That should pretty much do it. While you’re doing that, I’ll keep browsing your amazing artwork.

:smile: Thank you for your kind words about my illustrations :pray:

I’m not seeing the cloud icons on the four 198 IP addresses, unfortunately. Maybe they have disabled it.

There are two domains. One is the built-in one and the other is my primary one. The built-in one does not have any DNS/Nameserver sections that I can do any editing to any cloud icons.

See images in the following messages below :

!

EDIT: Never mind. I didn’t do my homework. Your site isn’t using Cloudflare at all. It’s still using Squarespace and nsone name servers, so anything you do at Cloudflare will not affect your domain.

Did you go through the entire onboarding process for your site? It would have included changing your name servers at your domain registrar, which appears to be Squarespace.

Click on the NAMESERVERS button. This should let you set them to the two listed at the bottom of your DNS page at dash.cloudflare.com

Ah okay!

I think I’ve got it right this time.

This should be all good, yes?

Thank you!
Maureen

Ah! (I didn’t do enough homework, as it looks like you’ve properly set the name servers).

I now see that the site is proxied through Cloudflare, so your country block should work.

Yay! Thank you so much for guiding me and being the ‘second pair of eyes’ :grinning_face_with_smiling_eyes:

I appreciate your time and being so patience in helping me :grinning_face_with_smiling_eyes:

Have a pleasant week ahead!

Kind regards,
Maureen

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.