Terrible website speed

Why is my website speed so slow?

I’m with Hostgator and using LiteSpeed Cache and ShortPixel Image Optimiser.

I added Cloudflare CDN and 3 page rules to cache static content.

However, looking at PageSpeed Insights I get a score of 38 on mobile and 71 on desktop.

https://developers.google.com/speed/pagespeed/insights/?url=https%3A%2F%2Fsimracingrx.com%2F&tab=mobile

And WEBPAGETEST gives me an “F” for Cache Static Content

Are LiteSpeed Cache and ShortPixel Image Optimiser conflicting with Cloudflare?

My website is https://simracingrx.com/

Any help would be appreciated.

Having multiple cache points might actually be worse than only having one from my experience. I would suggest only using CF but which one you use is up to you.

I would also suggest reading through the “Learn more” under each lab data (use the collapse button at the top right just above those lists for this to show up)

It can also give some more insight, as it seems it might not even be the caching itself that is the problem, rather all the added JS/CSS seems to slow it down considerably.
This shows up under Opportunities -> Eliminate render-blocking resources and gives some insight as well.

1 Like

Thanks for your reply knagie.

It’s really that first page’s TTFB that is killing you. Check out the waterfall here: https://webpagetest.org/result/200331_Y4_1d18ad14b9a78c92912d5f028af640d8/

That page is not being cached right now. If it is possible to cache it, then I would add Page Rules to do so… “Cache Everything” and maybe a TTL if you can’t set the cache headers.

If it is not possible to cache that page, then you’ll probably need to look at how to improve performance of page rendering on the server.

Thank you robertcope. A few hours ago I added a Page Rule to “Cache Everything” but I guess it’s not working.

I’m not sure what a TTL is but I’ll look into it.

Being new to this I’m looking at getting someone on Fiverr to help. is that a good idea?

Thanks.

I can’t speak to Fiverr, never heard of it…

The way that HTTP caching works is pretty simple; when an object is requested, one of the headers in the response can contain information on whether the object should be cached, how long it should be cached for (“time to live” or TTL), and other bits of metadata related to caching. Your request is not returning a cache headers, so Cloudflare isn’t going to cache it, despite “Cache Everything” being enabled.

You have two basic options if you want the page cached; you can configure your server to send the proper cache headers or you can update the “Cache Everything” rule to include a “edge cache ttl”, which will tell Cloudflare to cache the page for some period of time.

Make sense?

Thanks again for your help Robert.

I made some changes re your previous message - it’s running better now.

CloudFlare cache has little impact on FCB and FID. You have to rely on optimizing Wordpress to improve the performance. For example,

  • Reduce the size of background images
  • Lazy load images
  • Remove chaining critical requests

Moreover, as this page has less traffic, the field data is dependent on the performance of the whole site. So unless the other pages have done the similar optimization, the poor data from Chrome User Experience Report will not go easily.

Also, as @cuded2 stated, image optimization. By removing chaining, what is being said is essentially this:

Unburden you’re site from multiple requests for .CSS & .JS files. Instead, use what you need, combine the files into a single stylesheet for your css and a single javascript file for only the javascript you need. Load it (the javascript) in the bottom of your site’s markup. Load the stylesheet in your markup’s <head> - and do so from a local directory relative to your site’s root.

This topic was automatically closed after 30 days. New replies are no longer allowed.