Terraform plan error out on "Rate limited. Please wait and consider throttling your request speed (10000)"

We have our cloudflare DNS records managed with Terraform. When I run terraform plan inside the directory, it run for a while refreshing/matching the records with the state file in S3 bucket and then after a while it fails with bunch of errors saying

Error: HTTP status 429: Rate limited. Please wait and consider throttling your request speed (10000)

Is there a way I can bypass this or maybe request increase rate limit without getting charged for this?

You must be exceeding the 30/second limit. Unfortunately, I can’t find a way to lower the request rate in Terraform. Have you seen a way?

Though the documentation implies it can be increased. How my requests per second do you need?

This is surely an issue on my local since my colleague is able to run this from her local off the same branch without any issue. This also seems like something associated with my account because I tried it on another laptop which is recently build but got same error on it.

The rate is documented here, along with a way to customise the limit.

As it is a 5 minute rolling limit you might need to take a break for a few minutes before trying again.

1 Like

Actually, I figured out my Cloudflare API token was messed up. I rolled it out and things smoothen. Thanks for your response folks.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.