Telegram link preview doesn't work

This post was flagged by the community and is temporarily hidden.

When sharing a link, may I ask what exactly is not good? Title, description, or just the image not showing but all the other information is good?

If anything is blocked, it should appear under Firewall tab of Cloudflare dashboard for your domain name. Kindly, re-check Firewall Events if anything shown there.
Therefore, you may determine how to allow Telegram to display the needed image for further link sharing using.

Otherwise, if it’s a 3rd-party domain, something else could be a reason and you may not have any impact on it and it’s security options (like Hotlink, CORS, etc.).

He doesn’t friend anything at all.

Stuck in this state, directly from B2 it immediately loads the file (photo, video)

Firewall empty

Kindly, review your Bucket settings for CORS. It should fix this :wink:

I assume that since CloudFlare only works for me on https, then about this will work?

Hmmm, I’ll try sharing with everything first, if it works then I’ll try setting up the CORS further

1 Like

For testing/development purpose only, you can select “share everything in this bucket with every origin” - but I do not recommend using this option.

Furthermore, you can create a Page Rule at Cloudflare to cache all the files, in case if needed, to levarage traffic and serve cached files from Cloudflare cache.

If using social-cdn proxied :orange: sub-domain as a CNAME setup (below example):

1 Like

Yes I use proxying, do as you do, but I tweaked it a little bit, waiting 10 minutes to update the CORS settings

1 Like

For some reason it still doesn’t work

I don’t know what else to blame.

May I ask could you check for, hm… did you tried tu Purge the specific URL at Cloudflare → Caching → Configuration?

As far as this is just a URL address (link) to an image, I suppose you do not have to implement (neither where to if not a HTML webpage) the OpenGraph as stated in one of my previous posts here:

Upon changes, try to run “Debug” and then “Fetch new” at the Facebook Debug Tool here (you need to be logged-in):

Nevertheless, may I ask how big the image actually is (size in pixels) and how much data does it contain (megabytes)?

Is that correct link what I wrote down from your image?:

  • https://social-cdn.securetown.top/file/Social-Securetown/cache/media_attachments/files/107/649/688/557/214/755/original/38d82ef55654ac97.jpeg

I got this HTTP headers for it:

cache-control: public, max-age=315576000, immutable
cf-cache-status: HIT

Sorry it took me so long to reply, yes this is the test photo

1 Like

I tried using:

And sending it, but not sure if it’s cached so maybe we may have to wait for few hours, or not, despite “Purging the cache” for the URL address of the file (for testing now).

I clicked on both action buttons “Update preview again” and “Update with content”.

Other workaround adding ?v=n to the end where n can be any number:

  • https://social-cdn.securetown.top/file/Social-Securetown/cache/media_attachments/files/107/649/688/557/214/755/original/38d82ef55654ac97.jpeg?v=5

I will not be able to log in to Facbook, because I do not use it as a sign of dislike for the company

*Hotlink

Okay, I’ll wait 24 hours, and I’ll write about the result.

1 Like

And about OpenGraph, if you access b2 directly, the preview works
image

Interesting :smiley:

Do not forget to:

1 Like