Tech issue 502 Error

Hello guys,

I’m new here. I’m trying to creating my first campaign with Voluum DSP and I’ve got a tech issue mentioned about 502 error (as in the picture) I don’t know where to start to fix it.

Sorry if I’ve made any mistake posting this post. I don’t really know what to do. I really need to get this done now and move on to further process of the campaign making.

Thank you so much for your help in advance

choixcompany.club has got an A record, but track.choixcompany.club does not have an A record added at Cloudflare DNS dashboard.

;QUESTION
track.choixcompany.club. IN A
;ANSWER

;QUESTION
choixcompany.club. IN A
;ANSWER
choixcompany.club. 273 IN A 172.67.128.184
choixcompany.club. 273 IN A 104.21.2.51

If you own the domain choixcompany.club, make sure to point A www and A choixcompany.club to an IP address of your hosting provider.

Next one, make sure you also have an A track pointed to your hosting IP address.

More about how to add an A record to your domain (either a sub-domain) at Cloudflare DNS dashboard can be found at the below article:

Also, choixcompany.club returns me this:

Screenshot_2021-04-07 404 Not Found

1 Like

502 means bad gateway
Check the following (look below)

  • Ensure the origin server responds to requests for the hostname and domain within the visitor’s URL that generated the 502 or 504 error.
  • Investigate excessive server loads, crashes, or network failures.
  • Identify applications or services that timed out or were blocked.
    Also what’s the link to the website?
1 Like

Hey fritexvz,

Thank you so very much for your help.
In my DNS manage in picture, I have a lot of things going on which some of them I have created, but those with S3 amazon, I haven’t created. They automatically showed up. I’ve never registered Amazon host before.

Am I adding all the necessary record? Or is there any of them unnecessary adding and making a mess? I have GoDaddy as my domain name company and HostGator as the host.

By the way, choixcompany.club was working before but once I created landing page which is greenproduct.choixcompany.club, the original choixcompany.club turned to error 404 so I’m not sure what I’ve done wrongly.

1 Like

And my reply? Did it help at all?

Thank you so much William for your help.

But I’m kinda too new to understand what you mentioned because I’m not sure how to investigate excessive server loads, crashes or find what blocked the website.

link to the website is greenproduct.choixcompany.club if this what you’re asking for

No error

I checked now, and now I see it resolves - 404 error as expected (obviously).

I see it is pointed to Amazon S3 and also that CNAME records are set to :orange: (Proxied).

If you do not use Amazon S3, you can remove them and ignore the below content.

Maybe below article could help you:

S3 does not support https as clearly mentioned on this page (AWS docs):

The SSL certificate is only valid for *.s3.your-region.amazonaws.com.

If not using Amazon, then:

  1. Remove CNAME greenproduct.
  2. Edit A xgreenproduct to be A greenproduct (it is pointed to an IPv4 where the content should be right?).

Like this? Or do I need to get rid of all the Amazon because I don’t use Amazon

Seems like the tech issue still haven’t solved yet

Thank you so much by the way

Well, if you do not use Amazon S3 or at all, you are free to remove that DNS records.

Now when I visit the https://track.choixcompany.club/ or https://greenproduct.choixcompany.club/, both of them returns the 404 page from the host/origin server either due to the application routing or something else, but it is working over HTTPS.

Moreover your main domain https://choixcompany.club/ also returns some 404 not found from the amazon server as you have an record CNAME choixcompany.club pointed to amazon.

  • either it should be an CNAME choixcompany.club pointed to your hosting
  • or an A choixcompany.club and A www both pointed to your hosting IP address and both being :orange: cloud

May I ask which one? I do not see 502 error anymore.

I see you have an MX record pointed to mailhost.choixcompany.club, but you do not have an A mailhost record pointed to an IP address of your e-mail service provider (or it is the same as yoru hosting) - which should be :grey: cloud (DNS only).

2 Likes

Thank you so much, you’re so kind.

Right now I’ve delete all the Amazon and add more as shown in picture.

As Cloudflare mentioned above that I still need 2 steps to complete

  1. Add an A, AAAA, or CNAME record for root domain (I don’t know how)
  2. Add an MX record so mail can reach @choixcompany.club (I might skip this step if its okay)

Great.

That would be for example, having A www 192.185.52.166, but you already have CNAME www choixcompany.club - it’s okay.
If you really want to to respect that recommendation, then you would need to:

  1. Remove current CNAME www
  2. Add new record A www with the content value as the same IP address and make it also :orange: cloud.

You would need to:

  1. Modify MX mail to be MX choixcompany.club with the content value of mail.choixcompany.club
  2. Add new record A mail with the content value as the same IP address and make this one is set to :grey: cloud.

Maybe a easier to you if you would have it like the screenshot below:

No need to worry about a notification “some of your DNS only records are exposing IPs…” - you can ignore this one, because it is related to A mail record being :grey: cloud (DNS only) as it has to be like that, otherwise your e-mail would not function propperly.

2 Likes

Thank you so much for your effort. Right now my DNS looks exactly like picture you have shown.
I think it’s a good set up for DNS for now.

By the way, it still couldn’t fix the tech issue. As I plan to create the campaign with Voluum DSP, I need to fix this tech issue so I can have my first campaign.

1 Like

They referred to this screenshot implying my tech issue causing
https://screenshot.codewise.com/KatarzynaG/nn7xk_2021-04-06_10.21.11.png

Have you tried following this tutorial from Voluum DSP?:

Maybe, we actually need to have an CNAME track with content value of your Voluum DSP location and needs to be :grey: as written on the above link.

Can you try to find out your Voluum DSP location/name and create a CNAME track record with it being :grey:?

Just, before you do it, you would need to remove A track - otherwise you would get some notification that you already have an track record added.

And regarding the setup needed to be configured at Voluum DSP, you need to add your domain there too as far as I understand it.

looking through it. Thanks

I tried to put dedicated domain from the Voluum in the target, but they didn’t allow. Do you happen to know why?

The error says you have an record A track with the content value 192.185.52.166. Remove this one first, then re-try again adding a CNAME track with the target value jacesota-exture.icu.

1 Like

I think I’ve set up everything, now they still error but I guess I just have to wait for like 24 hours or something. Well, thank you very much. I don’t know what to say, I’ve got to one to ask but you have been helping me. Let me know if I can be helping you in any kind.

Thanks

1 Like