Teamspeak 3 DNS proxy not working correctly

There was a problem. Suddenly A record has stopped proxying the IP address The server cannot be connected by domain name. Teamspeak server. If you set DNS only, then you can connect, but the IP address becomes visible to everyone. How do I fix this? Sorry for my bad english.

1 Like

I have the same problem :frowning:

1 Like

Are you using a SRV record to point to Teamspeak?

It seems that something has changed/broken. You may try adding a :grey: DNS record for something like ‘ts.example.com’ (just ‘ts’ in DNS here) with the same IP address as the others. Then update your SRV record to point to it.

You may also want to open a ticket and ask if something has changed. Post the ticket # here so the mods can keep an eye on it.

From the beginning I did it and everything worked. And suddenly it stopped. I had to switch the A-record to “DNS only”. Because it was impossible to connect to the server by domain name.

What about “ticket”? I’m newbie, don’t know about that.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

Teamspeak Setup - this tutorial is not working animore. CF now is useless as a teamspeak defense. :frowning: Created a ticket, I’m waiting for the problem to be resolved.

Cloudflare was never defending teamspeak servers, as Cloudflare does not proxy the necessary connections. The tutorial you linked to already explained that.

I don’t know, but proxy worked before. And orig IP address was not shown to anyone, only CF IPs.

  1. Yes, the proxy to the website at that hostname would have worked.
  2. The Origin IP address would have been exposed to anybody snooping around your TeamSpeak SRV record. Just like an MX record that points to a proxied hostname, Cloudflare would have substituted in an alias with the actual origin IP address in order to make the connection:

Are all the tutorials on how to configure and “secure” Teamspeak servers with Cloudflare useless?

Hi there,

This is due to a bug we had yesterday. Please refer to my answer from this post:

Hope that helps.

3 Likes

At the moment everything seems to be working. Until the end of the week will be seen. Notified my users. Thanks.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.