Team domain page stuck loading - not opening across globe

I have created a Team Domain ( for Cloudflare Access apps, it was working fine initially, I was able to open the url and after authentication, it listing all the protected apps, but for last couple of weeks, when ever I am trying to access, it is getting stuck on loading screen, and it is same from across globe, I have tried accessing it from Australia, India, US, result is same.

Please do let me know how to fix this.

Saugata D.

Browser DevTools show two resources not loading:

Dunno why that is, though.

1 Like

They also 404 on a ‘working’ domain if you’re not logged in - but I’m getting JSON parsing errors on piaccess but not on any of my other Access pages.


1 Like

Oh, I see now.

/apps/data and /cdn-cgi/access/get-identity are returning HTML.

<!DOCTYPE html>
    <title>Error ・ Cloudflare Access</title>
    <meta charset="utf-8" />
    <meta name="robots" content="noindex" />
      content="initial-scale=1, maximum-scale=1, user-scalable=no, width=device-width"
<-- snip -->
    <div class="base_AccessLogo">
<-- snip -->
    <div class="Content">
      <div class="BarryWhitepaper">
<-- snip -->
      <div class="Message">
        <h2>Unable to find your Access organization!</h2>
        <p>It appears that you have attempted to reach an invalid URL. Please enter a valid team name.</p>
    <div class="base_TeamsLogo">
<-- snip -->

This is being parsed into JSON (and failing)


But, the actual error you’re interested in is sat in the HTML.

Unable to find your Access organization

IMO this should be handled a lot more gracefully


Thanks everyone for quick response, I fixed it, wrong DNS configured.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.