Teachable CName redirect URL changed after entering

#1

Hi, I’m trying to set up CName to forward from Teachable but after I enter the Teachable URL, the redirect is getting changed.

Under NAME field, I enter ‘[email protected]

After I add record, NAME field shows ‘american-business-basicsamericanbusinessbasics.comteachable.com

I’ve tried deleting and re-entering a new record 3 times and always switches back to this nonsense.

#2

I am not sure what you are trying to do but I am pretty sure it wont work :wink:

You are talking about redirects and posted an email address. Neither is related to CNAMEs.

Can you post a screenshot of what you configured and explain in simple terms what you would like to achieve?

#3

@sandro - I’m trying to follow directions in Teachable (Teachable custom domain instructions - https://support.teachable.com/hc/en-us/articles/222846328-Setting-Up-a-Custom-Domain) to set up forward from Teachable to Cloudflare custom domain (purchased on GoDaddy).

Part 1: Teachable provides a default domain - mine is:
[email protected] - I enter this in the ‘Name field’ in the CNAME new record entry.

Part 2: set Cname URL field to forward teachable domain to:
americanbusinessbasics.com (this is GoDaddy URL)

After I enter Part 1 and add a new record, the text in Part 1 (NAME field) changes to: american-business-basicsamericanbusinessbasics.comteachable.com (I’m not doing this, CloudFlare is changing it)

(I’ve tried to edit this multiple times but every time I add a new record and change NAME to [email protected] but after I hit ‘add record’ the field changes back to the nonsense URL)

Here’s the page:

#4

@sandro, OH, I’m typing in wrong Teachable with @ sign - I see it now - LOL such a dufus… user error… Looks like that worked. :hushed::roll_eyes::pensive:

2 Likes