SXGs breaking AMP pages with preload headers

AMP Pages doesn’t accept preload link headers. It’s fine if you preload in the HTML header, but trying to push in the request header generates AMP warnings, which affects rankings for those pages.

I have Automatic Signed Exchanges enabled in my account for a few weeks, but recently it started pushing the assets in AMP pages too. I don’t think it should work like that.

To use SXG, you need to disable AMP Automatic Signed Exchanges (SXGs) Beta Launch

  1. AMP Real URL needs to be disabled if SXGs is enabled:

Dashboard > Speed > Optimization > AMP Real URL

1 Like

I’m not using AMP Real Url.

SXG should be filtering AMP urls. I believe it stopped doing it recently (since november 2, according to my GSC)

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.