Switched OVH to Cloudflare - port 6690 to my stopped working

I use zerotier network to connect to my Synology NAS remotely. I have something.ovh domain and “A” record nas.something.ovh is set to ZT address given to the NAS. So far this worked fine with all services.
Yesterday i changed my DNSes from OVH to Cloudflare. CF automatically discovered and imported all records. They look fine, “A” record for nas.something.ovh is set directly to nas addres and IS NOT proxied through CF which is what i wanted. Web interface works fine, its TLS cert comes from synology. Yet Synology Drive doesnt want to connect at all. I checked it’s port

~$ telnet nas.something.ovh 443
Connected to nas.something.ovh.

~$ telnet nas.something.ovh 6690
telnet: Unable to connect to remote host: Connection refused

So does it mean that CF blocks this port? I havent seen and WAF rules.

You need to make sure nas.something.ovh is unproxied :grey:. By default Cloudflare only supports HTTP(S) traffic and only on certain ports. See: Network ports · Cloudflare Fundamentals docs.

If the record is already unproxied :grey: and you have cleared your DNS cache, then the problem is not with Cloudflare. You can check which IP addresses the domain resolves to with dig nas.something.ovh on Linux or nslookup nas.something.ovh on Windows.

Ok it turned out that it wasnt CF fault. It was an error in Synology software itself. And by coincidence it occured at the same time i switched my DNS servers. Thank you for your help @albert

Problem solved

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.