SvelteKit app build error in cloud flare pages

I used c3 to create a new SvelteKit app, added prettier and eslint and without any further customization or coding. I tried to deploy the app through my dashboard from the gitlab repo but a get an error concerning the node version of the environment not being compatible with some packages that eslint uses (it need above what Cloudflare default is) so I try to update the node version from the env using NODE_VERSION - 20
But nothing still changes, still having the same error, the node version I specified is not being used, how do I solve this

Hey,

Can you share the error you’re seeing?