Surfer plugin block the REST API endpoints or ports

Hi there!

I’m using the Surfer plugin in my WordPress, and this plugin requires REST API to work properly, but it seems that the server configuration may somehow block it.

Could you check on your end if there is anything that can block the REST API endpoints or ports? If this can help User-Agent for the Surfer request is: "SurferSEO WP Plugin.

Thanks

Will

Hi,

Only you can check what’s blocking your REST API endpoint.

  1. Visit your website with Dev Tools open (F12 on Chrome/Win) on the Network tab.
  2. Make a request that would trigger your plugin to make a REST API subrequest. Take note of the exact URL of this request.
  3. After it fails, wait a few minutes then go to Dashboard > Security > Events. You should find an event related to that block action, by filtering with URI Path.
  4. Open the Event log and check the “Service” that blocked it. If this was
    a) Bot Fight Mode, disable this feature.
    b) Super Block Fight Mode, create a WAF Custom Rule to Skip it for the specific situation (for instance, When incoming requests match... URI Path equals /wp-admin/uploads.php;
    c) WAF Managed Rule, you need to create a WAF Exception for that rule. See: Add a WAF exception in the dashboard · Cloudflare Web Application Firewall (WAF) docs and
    d) WAF Custom Rule, you need to edit it accordingly.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.